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ISl Getting Starte

* Launching ANSYS Electronics Desktop 2015

* Select Programs > ANSYS Electromagnetics > ANSYS Electromagnetics Suite 16.0
* Select ANSYS Electronics Desktop 2015.

* Open File
* Select File > Open... to open POEW_Finite_Array_WS.aedt
— Open the .aedt file you saved from the previous workshop: Unit Cell

WWWw.chantennas.com
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Copy/Paste Unit Cefl

— Right-click and select the menu item: Edit > Copy
* Inthe Project Manager window, select: POEW_WS

* Copy/Paste Unit Cell Design

* Inthe Project Manager window, select: 01_UnitCell (DrivenModal)

Project Manager

é 30 Components
----- &7 Model
B Boundaries
[} Excitations
..... BE Mesh Operations

Project Manaaer

roew_ws* ]
= @3 01_UnitCell (DrivenModal)
& 30 Components
& Model
# £ Boundaries
(*)-#3 Excitations
88 Mesh Operations

- JF Analysis &P Analysis
— Right-click and select the menu item: Edit > Paste i=-{ Optimetrics - (@) Optimetrics

[#1-[F] Results - [F) Results
@l Part Field Display @-[F Port Field Display
- Field Overlays @ T Field Overlays
- Radiation ¢ Radiation

(L] Definitions (&2 Definitions

* Rename Design
Project Manager 3 =

* Inthe Project Manager window, select: 01_UnitCelll (DrivenModal) = [ PoEW_ws

ﬁ- 01_UnitCell {DrivenModal)
(¢ 02_FiniteArrayDDM (DrivenModal)
é 30 Components
£ Model

— Inthe Project Manager window, minimize the Unit Cell design and expand Ejg -
theFiniteArrayddlicn B B4 B E B B B TR EBER psm W s Operations
[]---}5” Analysis

[]---.@ Cptimetrics

-] Results

@[ Port Field Display

----- % Field Overlays

[]---? Radiation

(-2 Definitions

— Right-click and select the menu item: Edit > Rename
* Rename design to: 02_FiniteArrayDDM

Note: We don’t want to invalidate the solution of the unit cell simulation because we will
want to use the mesh from this solution to solve the finite array design. By copy/pasting
the unit cell design to create the finite array design, we are ensuring that the unit cell used
to build the finite array is geometrically-equivalent to the one used in the unit cell
simulation --- in other words, we can safely use the same mesh in both designs.

www.chantennas.com
3 © 2015 ANSYS, Inc. May 6, 2015 Release 2015.0




Remove Fquuvé/WiA/c')?p,aig«]{ied1 Radiation Boundary

Remove Floquet Port

* Inthe Project Manager window, expand the Excitations list
— Select FloquetPort1
— Edit > Delete

Note: When we solve the finite array, we are no longer using Floquet analysis.

The radiation boundary condition assigned to the single unit cell will be used
across all elements of the finite array. This could be an ABC, PML or FE-BI.

Add Radiation Boundary

* Edit > Select > Faces

Project Manager
=[] POEW_ws*
(3-§# 01_UnitCell (DrivenModal)
= ¢ 02_FiniteArrayDDM (DrivenModal)*
6 3D Components
& Model
* £ Boundaries
= 2 Excitations
P Foqserorts
A9 WavePortl
8 Mesh Operations
¥ P Analysis
+ @ Optimetrics
) [¥] Results
+)-[#] Port Field Display
) \ Field Overlays
+ ? Radiation
-] Definitions

X

* Inthe 3D Modeler window, select the top face where the Floquet port was once defined

* HFSS >> Boundaries >> Assign >> Radiation
* Select OK

www.chantennas.com
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IVl Analysis Setup

* Driven Solution Set

* In the Project Manager Window, expand the Analysis list

up

* Double-click on Setup1

General tab
e Maximum Num
Options tab

ber of Passes: 1

e Uncheck Do Lambda Refinement

Advanced tab

* Check Import Mesh

Project Manager

= [ POEW_ws*

3 @ 01_UnitCel (DrivenModal)

= ¢ 02_FiniteArrayDDM (DrivenModal)*
é 3D Components

& Model

# £ Boundaries
= 2 Exdtations
£ WavePort1
#8 Mesh Operations

B Analysi

= 7

[+ @ Optime

- [7] Resuits

+ [ Port Field Display

+ g Field O

Y Radiation
+)-__] Definitions

S

trics

verlays

Driven Solution Setup == Driven Solution Setup (== Driven Solution Sef [l
plmrvs] Advanced | Expression Cache | Dervatives | Defauts | | Gene van:edl Expression Cache | Derivatives | Defaults | ' General | Options| Advanced | Expression Cache | Dervatives | Defauts |
i o, Init=] Mesh Option
Setup Name T — |—Inma\ Mesh Options T - —
B it e W import Mesh Setup Lirk..
1} i
[ Enabled [~ Solve Ports Only i =1 )
Port Options ———— — —
s = Spars Lan D
olution Frequency:  [10.8 GHz ~ 1 | ] Maximum Delta Zo: 0.2 %
Adaptive Opt — — — |
I H Ortiors | I Use Radiation Boundary On Ports
opkiaiSol e | Maximum Refinement Per Pass: 50 %
| ‘ ¥ Set Triangles for Wave Port
I Maxmum Number of Passes: 1 I [~ Madmum Refinement: 1
Mirimum: 300
: [
5 (i 001 Minimum Number of Passes: M 00
Minimum Converged Passes 1
" Use Matrix Convergence Fields
Solution Options V¥ Save Fields
Onder of Basis Funcions Err— I™ Save radiated fields only
Use Defaults

% Direct Solver \Jse Defadts

" herative Solver

" Domain Decompostion

0.0001
Use Defauts
HPC and Aralysis Options...
) oK Cancel oK Cancel
WM Crranténnas.com
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Note: These settings will ensure
that absolutely no additional
meshing will take place since we
are importing a well-converged
mesh from the unit cell model
for use in the finite array solve.
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IVl Analysis Setup

* Import Mesh
* General tab
— Check Use This Project
— Verify:
* Source Design: 01_UnitCell
* Source Solution: Setup1 : LastAdaptive
* Variable Mapping tab
— Select Map Variable by Name
* Additional mesh refinements tab
— Select Ignore mesh operations in target design
* Select OK

Setup Link ) Setup Link ) = Setup Link (3]
General I‘u"ariahle Mapping ‘ fddtional mesh refinemerts | General | Vaniable Mapping | Additional mesh refinements General ] Variable Mapping | Additional mesh refinements |
Product: HFSS Variable from Source Desigﬂ Value Mapped to Source Design | Unit | - Mesh eperations
J el . ™ Apply mesh operations in target design on the imported mesh
Fregl Freql
[P P (' Yanore mesh operations in target desiglﬂ
c [ |PMLH PML_H
= Phi_Scan Phi_Scan Port Adapt/Seeding
|T|1is Project” - POEW_W3 7T U ™ Perform port adapt/seeding in target solve setup
Theta_Scan Theta_Scan
Source Desian: [01_UnitCel =l |« x1
Source Solution: |S.31up1 : LastAdaptive j _xZ 2
¥l ¥l
¥2 y2
[T Simulate source design as needed [
™ Preserve source design solution
Note: In extractor mode, source project will be saved upon exit. I| Map Variable by Name ll
OK Cancel OK Cancel Cancel
ANAAALCI ST Illlﬁéc m
T O T TAATTCOTTITTCQAO . L]

LA A A A A
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Save Radiated Fields Only

niennas.com

* Check the box for Save radiated fields only

Select OK

Driven Solution Setup @
General l Options ~ Advanced | Expression Cache | Dervatives | Defaults |
Imitial Mesh Options
[v Import Mesh Setup Link... |
Part Options s
Maximum Delta Zo: 0.2
[ Use Radiation Boundary On Ports
[V Set Trangles for Wave Port
Minimurm: 300
Maimum: 800
Fields = = = oo =
[ Save Fislds
Dl? Save radiated fieids oniy: I
Use Defaults I
oK | Cancel

www.cnhantennas.com
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Note: For large finite arrays, solving all fields may
require significant disk space. In most cases, the
radiated fields are the only field solutions of
interest. How much disk space will you save by
doing this? One example: 9x5 patch array with 90
excitations saw a 23.6x reduction in disk space
(15.6GB with saved fields vs 0.66GB with save
radiated fields only option).
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* HFSS >> Model >> Create Array...

General tab

— Check the box for Visible
— Define Lattice Vectors and Array Size

EEE TiE

For A Vector: Master2
For B Vector: Master3
Active Cells tab

3
3

— Select the radio button for Padding

— Click on cells (1,1) and (3,3) to convert them from

Active to Padding cells

Select Apply
Select Close

www.chantennas.com
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W.Chantennas.com
Create Finite va

X Array Properties
General .‘Adive Cells I Post Processing Cell ]
MName: ’1‘7
Visible: W

Define Lattice Vectors and Amay Size
Boundary

Size

X Array Properties

General | Active Cells §Post Processing Cell

1

For A Vector: |Masler2 j |3
For B Vector: |Masler3 j |3
Padding Cells: ’1—
1
2
3
o

2113

Mouse makes cell: { Active { Passive FPaddlng

Al Active ] | Al Passive [] |

Apply Close

Release 2015.0




ISl Active vs Passive vs Pad: |rr|]fr;] as-com

Note:

* Active elements: the geometry of the unit cell is there, ports are active

* Passive elements: the geometry of the unit cell is there, ports are perfectly terminated

* Padding elements: the geometry of the unit cell is removed (cell is filled with air), ports do not exist

In the finite array simulation, padding elements border the entire array. These are not visible to the user. When comparing the finite array
DDM results to an explicitly drawn array of the same configuration, one must remember to include the air padding buffer around the
model as shown below.

Air buffer region
mimics DDM

9 © 2015 ANSYS, Inc. May 6, 2015 Release 2015.0
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Tools>>Options>>HPC and Analysis Options

Select the Configurations tab

WWW.cnantennas.com
ance Computing (HPC)

Add a finite array HPC configuration by selecting the “Add...” button

5| HPC and Analysis Options @
Design Type: |@ HFS5 j
Available Corfigurations: Configuration Details:
Active Name Total Tasks Make Active | |Corfigurstion Name:
local
Machine List S
Add... >
Edit. localhost:1:8
Job Distribution:
Q Optimetrics Variations
Frequencies
Copy... Transient Excitations
Domain Solver
Options:
Import... :i:::::::::::::
Desired RAMLimitinGE : 0
Export... MaxRAMLimitinGB : 0
OK | Canicel

Analysis Configuration

Configuration name: Finite_Array
Machine Details:
— Local machine

— Number of Tasks: 4

— Total Cores: 4 or greater (list total number of cores in your local machine)

Select Add Machine to List
In the Job Distribution tab, make sure that Domain Solver is checked

select OR/WW.Chantennas.com
© 2015 ANSYS, Inc.

May 6, 2015

] Analysis Configuration

&

|Conﬁgurahonname: | Finite_array |

T Use Automatic Settings

Machines | Job Distabution | Options |
Machines for Distibuted Analysis
Total Enabled Tasks: 0 Total Enabled Cores: 0

| Name \Tasks \ Cores \RAM Limit r;,)\ Enabled \

Machine Details:

&' Local machine

T IF Address format: 192.168.1.2)

€ DNS Name format: www server.com}:

€ UNC Name format: \\server)

Import Machines from File:

Add Machine to List ‘

s

oK

| cancel |

Machines for Distrbuted Analysis
Total Enabled Tasks: 4 Total Enabled Cores: 8

| Name [ Tasks [ Cores [ RAM Limit () [ Enabled |

| [localhest |2 g £ 2

il

Note: Can add more machines and distribute
the tasks across machines if local machine does
not have enough memory to solve the whole
problem. See slide 16 for more information for

how to choose number of tasks.
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Finite_Array HPC Con

11

HPC Cont’d

ntenpas.com
gurag'a

* Select the row labeled as Finite_Array from the Available Configurations list

* Inthe Active column, select the empty cell and toggle to YES

* Select OK

www.chantennas.com
© 2015 ANSYS, Inc.

7 HPC and Analysis Options

Corfigurations ] Options ]

Diesign Type: |@ HFS5

Awailzble Corfigurations:

=

Active | Name

| Total Tasks |

Make Active |

Local

it

Delete

Co

Import

Export

I am

Configuration Details:

Conﬂgumﬂon Mame:

Hnrte Ana','
Machine List:

localhost:4:8:90%

Job D|stnbut|or|

Optlmetncs ‘u’anatlons
Frequencies
Transient Excitations
Demain Salver

AllowOffCore : True

May 6, 2015

oK | Cancel
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NWSYSHE Why 4 Tasks?

Note: Finite array distributed domain method splits the problem into “domains” and solves the different domains in parallel for a more
efficient (less RAM, less time) solve. This requires at least 3 tasks: one task will be the “head node” and the other two tasks are domains.
4 tasks are defined here: one “head node” and 3 domains. The number of tasks assigned will distribute evenly across the available cores.
Should I assign 3 tasks (where two domains will be solved in parallel, each using 3 cores per domain) or 4 tasks (where three domains will
be solved in parallel, each using 2 cores per domain)? Our general recommendation for domain distribution problems is to assign 2-4
cores per task whenever possible while maximizing the number of domains you solve in parallel. Anymore than 4 cores per task may
amount to some speed-up in solve time, but not as much speed-up as what is seen between having 1 core per domain vs 2 cores per
domain (i.e., approx 2x).

Multi-Threading Processor Performance
Up to 5x faster solver.

8 Cores

4 Cores

2 Cores

1 Core (Baseline)

www.chantennas.com
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IVl Save and Analyze

* File >> Save

[ Validation Check: POEW WS - 02_FiniteArrayDDM @1
o . D | 5 i
* HFSS >> Validation Check o 02_FriebuayDDM ¥ Dosn Setinas
¥ Boundaries and Excitations
°
SeIeCt CIOSE Y alidation Check completed. o Mesh Operations
& Analysiz Setup
«¥ Optimetrics
' Radiation
* Note: Before running the simulation
disable or delete the optometric setup. 2 ]
* HFSS >> Analyze All
(== & PoEw_ws . : :
. @ 02 Finite AmayDDM (DrivenModal) Note: This warning message is ok! Remember we
ﬂ Setupl : LastAdaptive distibuting Domain Solver (3:52:52 PM May 26, 2014) sta rted th|s S|mu|ation by |mport|ng a We“-
i, Adaptive Passes did not converge based on specified criteria. (3:55.32 PM May 26, 2014) @ .
ﬂ Nomal completion of simulation on server: Local Machine. (3:55:33 PM May 26, 2014) Converged mesh from the unit cell model and then

we limited number of adaptive passes to 1.

Message Manager

WWWw.chantennas.com
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INYN'Al Edit Sources

 HFSS >> Fields >> Edit Sources

* In the Magnitude column, change all 0 values to 1
* In the Phase column, change every other value from 0 to 90

* Select Apply Eatpost

* Select Close

Source | Type | Magnitude: Unit Phase | Unit
o E N )

2 Al 2[WaveFort1:2 Fort Tw 90 deg
B A1, 3WavePort1:1 Port Tw 0 deg
g Al1.3WavePort1:2 Port Tw 90 deg
= A2 TWavePort1:1 Port Tw 0 deg
B Al2,1]WaveFort1:2 Port 1w 90 deg
(71 Al22)WavePort1:1 Port 1w 0 deg
B A2 2\WavePort1:2 Port 1w 90 deg
B A2 3WavePort1:1 Port Tw 0 deg
[ o] Al2.3WaveFort1:2 Port 1w 90 deg
K A3 TWavePort 1:1 Port 1w 0 deg
[ 2] A[3.1[WavePort1:2 Port TW 90 deg
[ A[3.2)WavePort1:1 Port 1w 0 deg
4 A3 2\WavePort1:2 Port; 1W 90 deg

T Include Port Post Processing Effects

Save to file Load From File |

OK I Cancel | | Help

Note: The default Solution Type in HFSS is Network Analysis (HFSS >> Solution Type). This solution type solves for every possible excitation
so editing the magnitude and phase at each port is a post-processing step that scales the field solutions accordingly. To solve for only one
excitation scheme (much faster solve for finite arrays with a large number of ports), select HFSS >> Solution Type and toggle the radio
button from Network Analysis to Composite Excitation. In a Composite Excitation solve, the above Edit Sources dialogue will no longer be
a post-processing window — changes to the excitations will require a re-solve for fields to update.

Wwww.chantennas.com
14 © 2015 ANSYS, Inc. May 6, 2015 Release 2015.0



e SYZ Results

* In the Project Manager window, expand the Analysis list and expand the list

under Setupl

.cnantennas.com

Network Data Expiorer

Project Manager

=] POEW_WS*

&8 01_UnitCell (DrivenModal)

=] ﬁ 02_FiniteAmrayDDM (DrivenModal)*
2-&2 Model

-EF Boundaries

° . . "
Right-mouse-click on Sweep >> Network Data Explorer e Exctations
----- B8 Mesh Operations
® 1 1 1 =-JF Analysis
View results, export results (select Broadband to view export options) fg’ég -y
[
. ndExplorer EI [=) |@ : @ Optimetrics Copy Ctrl+C
File Edit Plot -2 Resuts Rename F2
& Radiatior n
Delete Delete
E: t Chedk x =
Metwork data file: |Setup1 : Swesp =] srowse... s = - ﬂ_ 3D Palar -
SYZ Data I Causality | 5[ Port Field Dig Properties...
Compare matrix data Quantity Parameter type - |—Format — Broadband | []---ﬁ Field Owverlay Disable Sweep
Mo compare ~| |Parameter values | [5 parameter ~| |8 R4 b []"'? Radiation Analyze
= n —1 -2 Defintions
Y parameter Network Data Explorer...
Z parameter
Port Impedance =
e Project ’7 Create Quick Report...
Perform FFT on Report ...
Selectby: (" Frequencies % Matrix entries view: { Table ™ Plot
dB(S) »
-12.50 Curve Info
S(A[1,2]WavePort1:1, : ] B
S(ALL,2]WavePort1: 1, A[2, )WavePart1: i — dB{S(AI1, 2MWavePort1. 1, Al1 2lWavePorti:1)) dx="1...,
4 -15.00 - Setup1 : Sweep
S(A[1,2]WavePort1:1, A[2, 1] WavePort1: 9 dx="1.100787037in’' dy="0.3178351852in' FreqH="1.08E=01...
S(A[1,2]WavePort1:1, A[2, 2] WavePorti: 1) 3 —— dB(S(A[,2WavePort1 1, A[1,3]WavePort1:1)) dx=1...|
S{A[1,2lWavePort1:1, A[2,2]WavePort1:2) -17.50 —} Setup1 : Sweep
S(A[1,2]WavePort1:1, A[2,3]WavePort1:1) ] dx="1.100787037in' dy="0.3178351852in' FreqH="1.08E+01...
S(A[1,2]WavePort1:1, A[2,3]WavePort1:2) 1
S(A[1,2]WavePort1:1, A[3,1]WavePort1:1) -20.00
S(A[1,2]WavePort1:1, A[3,1]WavePort1:2) ]
S(A[1,2]WavePort1:1, A[3,2]WavePortl:1) 22 50
S(A[1,2]WavePort1:1, A[3,2]WavePort1:2) @ ]
S(A[1,2]WavePort1:2, A[1,2)WavePort1:1) 3 2500 ]
S(A[1,2]WavePort1:2, A[1,2]WavePort1:2) e
S(A[1,2]WavePort1:2, A[1,3]WavePort1: 1) ]
S(A[1,2]WavePort1:2, A[1,3]WavePort1:2) 2750 4
S(A[1,2]WavePort1:2, A[2,1]WavePort1:1) ]
" : " : ]
ettt e e || 003
™ Selectall ]
-32.50
-35.00 T T T T T
920 9.40 Qéﬂ Qé[] 10.00 1020 10.40 1060 1080
Frequency [GHz]
[V Select all
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IVl 2D Radiation Pattern

e Radiation Setup
HFSS >> Radiation >> Insert Far Field Setup >> Infinite Sphere...
— Name: FF_2D

16

Total Directivity

— Phi

e Start: Odeg
e Stop: 90deg
* Step:90deg

— Theta

e Start: -180deg

e Stop:180deg

e Step: 1deg
Select OK

HFSS >> Results >> Create Far Field Report >> Radiation Pattern
Category: Directivity

Quantity: DirTotal

Function: dB

Select New Report

Select Close

Far Field Radiation Sphere Setup @
Infinte Sphere | Coordinate System | Radiation Surace |

Name _[FF_2D

Phi
Start 0 deg -
Stop 50 deg -
Step Size |30 deg -

Theta
Start 180 deg -
Stop 180 deg -
Step Size |1 deg -
Save Az Defaults I View Sweep Points.... |

Cancel Help.

www.cnhantennas.com
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Radiation Pattern 1

02_FiniteArayDDM

Curve info
— dB(DirTotal
Setup1 : LastAs a;tive
Freq="10.8GHz' Phi="0deg'
— dB(DirTota‘? .

tive

Setup1 : LastAs aFP
Freq="10.8GHz' Phi="90deg’

Release 2015.0
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INYS'SE 3D Polar Plot

* Radiation Setup

17

HFSS >> Radiation >> Insert Far Field Setup >> Infinite Sphere...

— Name: FF_3D
— Phi
e Start: Odeg
e Stop:360deg
e Step: 1deg
— Theta
e Start: Odeg
* Stop:180deg
* Step: 1deg
Select OK

Total Gain

HFSS >> Results >> Create Far Field Report >> 3D Polar Plot
In the Context field, select FF_3D from the Geometry drop-down menu

Category: Gain
Quantity: GainTotal
Function: dB

Select New Report

Far Field Radiation Sphere Setup

Infinite Sphere | Coordinate System ‘ Radiation Surface |

Neme [FF_3D

Fhi

==

Sat o ldeg v
Stop J360 [deg =]
Step Size |1 |deg j
"Theta R 1l
Start |D i |deg j
Siop [180 ldeg  v|
Step Size |'I |deg j
Save As Defaults_l View Sweep Poirﬂs.J
Ok | | Cancel | Help |

Select Qlasey . cnantennas.com
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Overlay Plot

18

Window >> 2 POEW_WS - 02_FiniteArrayDDM - Modeler

Relative Coordinate System
* Modeler >> Coordinate System >> Create >> Relative CS >> Offset

* Inthe data entry fields at the bottom of the HFSS working window,
enter the following (use the Tab key to move from field to field):

- X:0

- Y:-550

- Z2:0

— Click the Enter key on your keyboard to finish data entry

Modify Radiation Setup

* In the Project Manager window, expand the Radiation list

* Double-click on FF_3D

* Inthe Coordinate System tab, select Use local coordinate system
* Select RelativeCS1 from the drop-down menu

* Select OK Overlay radiation field: POEW_WS - 02_FiniteArrayDDM
. . . " . | Name I Visible |Transparer1c5«I | Scale |
HFSS >> Flelds >> PIOt Flelds >> Rad’at’on Fleld 3D Polar Plot 1 Ira 0.30 0.3

®* Check the box for Visible
* Transparency: 0.3, Scale: 0.8
* Select Apply

ey Close

* Select ClaseV.Ccnantennas.com
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