Workshop 8-1: Hybrid Simulation of a Reflector Antenna

ANSYS HFSS for Antenna Design
Example – Horn-Fed Reflector Antenna

- **Horn-Fed Reflector Antenna**
  - This example is intended to show you how to create, simulate, and analyze horn-fed reflector antenna system efficiently, using the ANSYS Electronics Desktop; HFSS and HFSS-IE Design Environments.
    - Part 1: HFSS Design of horn antenna
    - Part 2: HFSS-IE design of reflector with excitation linking to HFSS design in part 1. Antenna solution using an Integral Equation and Physical Optics solution methods, both techniques are available within HFSS-IE.
    - Part 3: HFSS Hybrid design of a reflector + horn antenna
    - Part 4 – HFSS Hybrid Setup with Mesh Assembly
    - Part 5: Placement study with Mesh Reuse

**Input files:**
- Horn_10GHz.a3dcomp
- horn_FEBI_boundary.a3dcomp
- Reflector_IERegion_curvi.a3dcomp

www.cnantennas.com
HFSS: Getting Started

• Launching ANSYS Electronics Desktop 2015
  • Select *Programs > ANSYS Electromagnetics > ANSYS Electromagnetics Suite 16.0*
  • Select *ANSYS Electronics Desktop 2015.*

• Setting Tool Options
  • **Note:** In order to follow the steps outlined in this example, verify that the following tool options are set:
  • Select the menu item *Tools > Options > HFSS Options…*
    – Click the **General** tab
      • Use Wizards for data input when creating new boundaries: ☑️ Checked
      • Duplicate boundaries/mesh operations with geometry: ☑️ Checked
    – Click the **OK** button
  • Select the menu item *Tools > Options > Modeler Options…..*
    – Click the **Operation** tab
      • Automatically cover closed polylines: ☑️ Checked
      • Select last command on object select: ☑️ Checked
    – Click the **Drawing** tab
      • Edit properties of new primitives: ☑️ Checked
    – Click the **OK** button
Part 1 - HFSS: Creating the Horn Antenna

• Opening a New Project
  • In HFSS Desktop, click the On the Standard toolbar, or select the menu item File > New.
  • From the Project menu, select Insert HFSS Design.

• Set Solution Type
  • Select the menu item HFSS > Solution Type
    – Choose Driven Modal
    – Choose Network Analysis
    – Click the OK button

• Set Model Units
  • Select the menu item Modeler > Units
    – Select Units: in
    – Click the OK button
Creating the Horn Antenna

- Select the menu item **Draw > 3D Component Library > Browse**
  - Browse 3D Component Dialog
  - Filename: **Horn_10GHz.a3dcomp**
  - Click the **Open** button
  - Insert 3D Component Dialog
    - FlareA: **2.65in**
    - FlareB: **1.95in**
    - Horn_length: **5.2in**
    - Click the **OK** button
- To fit the view:
  - Select the menu item **View > Fit All > Active View**. Or press the CTRL+D key
Example – Horn-Fed Reflector Antenna

• Creating the Airbox
  • Select the menu item Draw > Region
    – Padding Data: Pad all directions similarly
    – Direction: All
    – Padding type: Absolute Offset
    – Value: 0.3in
    – Click the OK button

• Create Radiation Boundary
  • Select the menu item Edit > Select > By Name
    – Object Name: Region
    – Click the OK button
  • Select the menu item HFSS > Boundaries > Assign > Radiation...
    – Click the OK button

• Create a Radiation Setup
  • Select the menu item HFSS > Radiation > Insert Far Field Setup > Infinite Sphere
    – Infinite Sphere Tab
      • Name: 2D
      • Phi: (Start: 0, Stop: 90, Step Size: 90)
      • Theta: (Start: -180, Stop: 180, Step Size: 1)
    – Click the OK button
**HFSS: Analysis Setup**

**Creating an Analysis Setup**
- Select the menu item *HFSS > Analysis Setup > Add Solution Setup*
  - Click the **General** tab:
    - Solution Frequency: **10 GHz**
    - Maximum Number of Passes: **6**
    - Maximum Delta S per Pass: **0.02**
  - Click the **OK** button

**Save Project**
- Select the menu item *File > Save As*
  - Filename: **Reflector**
  - Click the **Save** button

**Source Design Analyze**
- Select the menu item *HFSS > Analyze All*
Part 2 - HFSS-IE: Getting Started

- **Setting Tool Options**
  - **Note:** In order to follow the steps outlined in this example, verify that the following tool options are set:
    - Select the menu item **Tools > Options > HFSS-IE Options**
      - Click the **General** tab
        - Use Wizards for data input when creating new boundaries: **Checked**
        - Duplicate boundaries/mesh operations with geometry: **Checked**
      - Click the **OK** button

- **Opening a New Project**
  - Select the menu item **Project > Insert HFSS-IE Design**

- **Set Model Units**
  - Select the menu item **Modeler > Units**
    - Select Units: **in**
    - Click the **OK** button
**HFSS-IE: Creating the 3D Model**

- **Create Reflector**
  - Select the menu item *Draw > Equation Based Curve*
    - \( X(t): 0 \)
    - \( Y(t): (t)(1cm) \)
    - \( Z(t): (26.625-t^2/106.5)(-1cm) \)
    - Start \( t \): 0
    - End \( t \): 32
    - Number of Points: 0
    - Click the OK button
  - Select the menu item *Edit > Select All*
  - Select the menu item *Draw > Sweep Around Axis*
    - Sweep axis: \( Z \)
    - Angle of sweep: 360 deg
    - Draft angle: 0
    - Draft type: Round
    - Number of segments: 0
    - Click the OK button
  - To fit the view:
    - Select the menu item *View > Fit All > Active View*. Or press the CTRL+D key

- **Assign PEC**
  - Select the menu item *Edit > Select All*
  - Select the menu item *HFSS-IE > Boundaries > Assign > Perfect E*
    - Click the OK button

*Note: The End \( t \) intrinsic variable is going to control the radius of the reflector. For this example, if you would like, you can use a smaller radius to decrease the simulation time, for example set End \( T \) = 15, and continue with the steps as described in this workshop.*
 HFSS-IE: Defining the Linked Excitation

- **Create Linked Excitation**
  - Select the menu item **HFSS-IE > Excitations > Assign > Incident Wave > Near Field Wave**
    - **General Data**
      - Name: **Feed**
      - Vector Input Format: **Cartesian**
      - Click the **Next** button
    - **Near Field Wave options**
      - Theta (rotation about the resultant X-axis): **180deg**
      - Click the **Setup Link** button
        - Product: **HFSS**
        - Source Project: **Use This Project**
        - Source Design: **HFSSDesign1**
        - Source Solution: **Setup1: LastAdaptive**
        - Simulate source design as needed: **✓**
        - Preserve source design solution: **✓**
        - Click the **OK** button
      - Click the **Finish** button
HFSS-IE: Analysis Setup

• Apply Mesh Operations
  • Select the menu item **HFSS-IE > Mesh Operations > Initial Mesh Settings**
    – ☑ Apply curvilinear elements
    – Click the OK button

• Creating a IE Analysis Setup
  • Select the menu item **HFSS-IE > Analysis Setup > Add Solution Setup**
    – Click the General tab:
      • Setup Name: IE_Setup
      • Solution Frequency: 10GHz
      • Maximum Number of Passes: 1
      • Maximum Delta E per Pass: 0.1
    – Click the Options tab
      • Select Solver Type: Use ACA Solver
    – Click the OK button

**Extra:** Curvilinear mesh elements conform more accurately to curved bodies. This allows for more accurate and usually faster simulation when the model geometry requires a very accurate representation of fields on a curved surface. Models like this reflector or RCS of a curved surface most often benefit from these curvilinear mesh elements.
HFSS-IE: Analysis Setup

- Creating a PO Analysis Setup
  - Select the menu item **HFSS-IE > Analysis Setup > Add Solution Setup**
    - Click the **General** tab:
      - Setup Name: PO_Setup
      - Solution Frequency: **10GHz**
      - Maximum Number of Passes: **1**
      - Maximum Delta E per Pass: **0.1**
    - Click the **Options** tab:
      - Select Solver Type: **Use PO Solver**
    - Click the **OK** button
**HFSS-IE: Analysis Setup**

- **Create a Radiation Setup**
  - Select the menu item *HFSS-IE > Radiation > Insert Far Field Setup > Infinite Sphere*
    - **Infinite Sphere Tab**
      - Name: **3D**
      - Phi: (Start: 0, Stop: 360, Step Size: 2)
      - Theta: (Start: 0, Stop: 180, Step Size: 1)
    - Click the **OK** button

- **Save Project**
  - Click the menu item *File > Save*

- **Reflector Design Analyze**
  - Select the menu item *HFSS-IE > Analyze All*
HFSS-IE: Plotting Field Results

• **Create Current Plot for IE Solution**
  - Select the menu item *Edit > Select All*
  - Select the menu item *HFSS-IE > Fields > Fields > J > Mag_J*
    - Solution: *IE_Setup*: *LastAdaptive*
    - Frequency: **10GHz**
    - Phase: **0deg**
    - Quantity: **Mag_J**
    - Click the **Done** button

• **Change the Plot Scale to Log**
  - Select the menu item *HFSS-IE > Fields > Modify Plot Attributes*
    - In the Select Plot Folder Window, Click the **OK** button
    - J-Fields Window:
      - Click the Scale tab
        - Scale: **Log**
      - If real time mode is not checked, click the **Apply** button.
    - Click the **Close** button
  - To Animate the field plot:
    - Select the menu item *HFSS-IE > Fields > Animate*
    - Click the **OK** button
HFSS-IE: 3D Pattern Results

- Create 3D Far Field Pattern for IE Solution
  - Select the menu item `HFSS-IE > Results > Create Far Fields Report > 3D Polar Plot`
  - Solution: `IE_Setup: LastAdaptive`
  - Geometry: 3D
  - Primary Sweep: Phi
  - Secondary Sweep: Theta
  - Category: Directivity
  - Quantity: DirTotal
  - Function: dB
  - Click the New Report button

- Create 3D Far Field Pattern for PO Solution
  - Solution: `PO_Setup: LastAdaptive`
  - Geometry: 3D
  - Primary Sweep: Phi
  - Secondary Sweep: Theta
  - Category: Directivity
  - Quantity: DirTotal
  - Function: dB
  - Click the New Report button

- Click the Close button
HFSS-IE: 2D Pattern Results

- Create 2D Far Field Pattern of IE and PO to compare results
  - Create 2D Far Field Pattern
  - Select the menu item HFSS-IE > Results > Create Far Fields Report > Rectangular Plot
    - Solution: IE_Setup: LastAdaptive
    - Geometry: 3D
    - Primary Sweep: Theta
    - Category: Directivity
    - Quantity: DirTotal
    - Function: dB
    - From the Families tab select the value of 90deg for Phi
    - Click the New Report button
  - Solution: PO_Setup: LastAdaptive
    - Click the Add Trace button
    - Click the Close button

**Note:** We can use this plot to compare the differences between the PO solution and IE solution. PO and IE solution show good agreement in main beam, but differ when PO approximations start to become apparent. For example edge effects would not be considered with the PO solver.
Part 3 – HFSS Hybrid Setup

• Opening a New Project
  • In HFSS Desktop, click the  On the Standard toolbar, or select the menu item File > New.
  • From the Project menu, select Insert HFSS Design.

• Set Solution Type
  • Select the menu item HFSS > Solution Type
    – Choose Driven Modal
    – Choose Network Analysis
    – Click the OK button

• Set Model Units
  • Select the menu item Modeler > Units
    – Select Units: in
    – Click the OK button
• Creating the Horn Antenna
  • Select the menu item Draw > 3D Component Library > Browse
    – Browse 3D Component Dialog
      • Filename: Horn_10GHz.a3dcomp
      • Click the Open button
    – Insert 3D Component Dialog
      • FlareA: 2.65in
      • FlareB: 1.95in
      • Horn_length: 5.2in
      • Click the OK button
  • Rotate the Horn
    – Select the menu item Edit > Arrange > Rotate
      • Axis: X
      • Angle: 180 deg
      • Click the OK button
  • To fit the view:
    – Select the menu item View > Fit All > Active View. Or press the CTRL+D key
Creating the Airbox
- Select the menu item **Draw > Box**
  - Using the coordinate entry fields, enter the box origin
    - X: -1.675, Y: -1.325, Z: -0.3, Press the Enter key
  - Using the coordinate entry fields, enter the size of the box:
    - dX: 3.35, dY: 2.65, dZ: 6.8, Press the Enter key
- Select the **Attribute** tab from the Properties window.
  - For the **Value** of **Name** type: Airbox
  - Display Wireframe: ✔ Checked
  - Click the OK button

To fit the view:
- Select the menu item **View > Fit All > Active View**. Or press CTRL+D

Create Radiation Boundary
- Select the menu item **Edit > Select > By Name**
  - Object Name: Airbox
  - Click the OK button
- Select the menu item **HFSS > Boundaries > Assign > Radiation**...
  - Model exterior as HFSS-IE domain: ✔ Checked
  - Include for near/far field calculation: ✔ Checked
  - Click the OK button
**Create Reflector**

- Select the menu item *Draw > Equation Based Curve*
  - \( X(_t) = 0 \)
  - \( Y(_t) = (_t) \times (1 \text{cm}) \)
  - \( Z(_t) = (26.625 - _t \times _t / 106.5) \times (-1 \text{cm}) \)
  - Start \(_t\): 0
  - End \(_t\): 32
  - Number of Points: 0
  - Click the **OK** button

- Select the **Attribute** tab from the **Properties** window.
  - For the **Value** of **Name** type: *Reflector*
  - Click the **OK** button

- Select the menu item *Edit > Select > By Name*
  - Object Name: *Reflector*
  - Click the **OK** button

- Select the menu item *Draw > Sweep > Around Axis*
  - Sweep axis: *Z*
  - Angle of sweep: **360 deg**
  - Draft angle: 0
  - Draft type: *Round*
  - Number of segments: 0
  - Click the **OK** button
HFSS Hybrid: Reflector IE Region

• Assign PEC
  • Select the menu item *Edit > Select > By Name*
    – Object Name: *Reflector*
    – Click the OK button
  • Select the menu item *HFSS > Boundaries > Assign > Perfect E*
    – Click the OK button

• Assign IE Region
  • Select the menu item *Edit > Select > By Name*
    – Object Name: *Reflector*
    – Click the OK button
  • Select the menu item *HFSS > IE Regions > Assign As IE Region*
    – Click the OK button

• View IE Regions
  • Select the menu item *HFSS > IE Regions > View IE Regions*
    – Click the Close button
Radiation Sphere Setup

• **Create a Radiation Setup**
  • Select the menu item *HFSS > Radiation > Insert Far Field Setup > Infinite Sphere*
    – Infinite Sphere Tab
      • Name: **3D**
      • Phi: (Start: 0, Stop: 360, Step Size: 2)
      • Theta: (Start: 0, Stop: 180, Step Size: 1)
    – Click the **OK** button
HFSS: Analysis Setup

- **Apply Mesh Operations**
  - Select the menu item *HFSS > Mesh Operations > Initial Mesh Settings*
    - **Apply curvilinear elements**
    - Click the OK button

- **Creating an Analysis Setup**
  - Select the menu item *HFSS > Analysis Setup > Add Solution Setup*
    - Click the General tab:
      - **Solution Frequency:** 10 GHz
      - **Maximum Number of Passes:** 6
      - **Maximum Delta S per Pass:** 0.02
    - Click the OK button

- **Save Project**
  - Select the menu item *File > Save As*
    - Filename: Reflector_Hybrid
    - Click the Save button

- **Source Design Analyze**
  - Select the menu item *HFSS > Analyze All*

**Note:** The Hybrid simulation requires ~4.5GB of RAM

**Note:** curvilinear mesh elements will be used for the horn and the reflector.
HFSS Hybrid: Results

**Create Current Plot**
- Select the menu item *Edit > Select > By Name*
  - Object Name: **Reflector**
  - Click the **OK** button
- Select the menu item *HFSS > Fields > Plot IE Surface Fields > J > Mag_J*
  - Solution: **Setup1: LastAdaptive**
  - Frequency: **10GHz**
  - Phase: **0deg**
  - Quantity: **Mag_J**
  - Click the **Done** button

**Change the Plot Scale to Log**
- Select the menu item *HFSS > Fields > Modify Plot Attributes*
  - In the Select Plot Folder Window, Click the **OK** button
  - J-Fields Window:
    - Click the Scale tab
      - Scale: **Log**
    - If real time mode is not checked, click the **Apply** button.
  - Click the **Close** button
- To Animate the field plot:
  - Select the menu item *HFSS > Fields > Animate*
  - Click the **OK** button
HFSS Hybrid: Results

- **Create 3D Far Field Pattern**
  - Select the menu item *HFSS > Results > Create Far Fields Report > 3D Polar Plot*
  - Solution: *Setup1: LastAdaptive*
  - Geometry: *3D*
  - Primary Sweep: *Phi*
  - Secondary Sweep: *Theta*
  - Category: *Directivity*
  - Quantity: *DirTotal*
  - Function: *dB*
  - Click the *New Report* button
  - Click the *Close* button

- **Challenge: Create a 2D far field pattern that compares the result from this full hybrid analysis with the solution from the data-linked solutions (PO and IE)**
  - Run an analysis using only the IE solver that includes the blockage effects of the feed, see next slide for additional tips
Note: HFSS-IE with Blockage

• Including the Horn blockage in HFSS-IE
  • You can see from the field patterns on the reflector that the HFSS Hybrid simulation is different from the HFSS-IE simulation with the horn antenna data linked. The difference is caused by the horn blockage. To include the horn blockage in the HFSS-IE simulation, the geometry for the horn antenna needs to be selected prior to creating the near-field source excitation. The field data for the horn is still data linked.
  • Below are the HFSS-IE results when the Horn is included for blockage.
Opening a New HFSS design

- From the Project menu, select Insert HFSS Design.
- Check that solution type is Driven Modal Network Analysis.
- Change model unites to in.

Insert 3D component for the Horn Antenna

- Select the menu item Draw > 3D Component Library > Browse
  - Browse 3D Component Dialog
    - Filename: horn_FEBI_boundary.a3dcomp
    - Click the Open button
  - Insert 3D Component Dialog
    - FlareA: 2.65in
    - FlareB: 1.95in
    - Horn_length: 5.2in
    - Rad_dist: 0.3in
    - Click the OK button

Insert 3D component for the reflector

- Select the menu item Draw > 3D Component Library > Browse
  - Browse 3D Component Dialog
    - Filename: Reflector_IERegion_curvi.a3dcomp
    - Click the Open button
  - Insert 3D Component Dialog
    - focus: 10, Ref_rad: 6, Click the OK button
Align and parameterize geometry

- **Rotate the horn**
  - Select the submodel for horn by clicking on HFSSDesign1_1 line in Model Tree window
  - Note that all objects of the submodel are highlighted in Modeler window
  - Select the menu item *Edit > Arrange > Rotate*
    - Axis: Y, Angle: -90deg
    - Click the *Ok* button
  - To fit the view:
    - Select the menu item *View > Fit All > Active View*. Or press the CTRL+D key

- **Check submodel properties for the horn**
  - Right click on HFSSDesign1_1 line in Model Tree window
  - Choose *Properties*
  - Open *Component Meshing* tab
    - Do Mesh Assembly: **Checked**
    - Note that Apply curvilinear elements are not checked

Mesh operations settings like Initial Mesh Method, surface approximation etc. are the part of the component data. If “Do Mesh Assembly” option is enabled, 3D components are meshed separately and use appropriate mesh settings for each component.
Align and parameterize geometry

• **Create Offset Relative Coordinate System**
  • Make sure that **Global** is the working coordinate system
  • Select the menu item **Modeler > Coordinate System > Create > Relative CS > Offset**
    – Press and hold **Z key** to restrict cursor movement along **Z** axis of working coordinate system
    – Click anywhere along the negative direction of **Z** axis to indicate the origin of the new coordinate system
    – Expand **Coordinate Systems** line in Modeler Tree window. **RelativeCS1** will be used to parameterize distance between horn and reflector
  • Rename and parameterize **RelativeCS1**
    – Double click on **RelativeCS1** line in Modeler tree
      • Type **reflector_focus** as a new name in the popup window
      • Origin: 0,0,-offset
    • Type **0** as Value in Add Variable popup window
      – Click the **OK** button
  • Click the **OK** button
Align and parameterize geometry

- **Change reference coordinate system for reflector submodel**
  - Click on reflector1 line in Model Tree window
  - In the **Properties** window, change coordinate system from **Global** to **reflector_focus**

- **Check submodel properties for the reflector**
  - Right click on reflector1 line in Model Tree window
  - Choose **Properties**
  - Open **Component Meshing** tab
    - Do Mesh Assembly: ✔ Checked
    - Note that Apply curvilinear elements are checked
  - Open **IE Domains** tab
    - Check that object reflector_1 is assigned as IE Region
HFSS: Analysis and HPC Setup

1. Creating an Analysis Setup
   - Select the menu item **HFSS > Analysis Setup > Add Solution Setup**
     - Click the **General** tab:
       - **Solution Frequency**: 10 GHz
       - **Maximum Number of Passes**: 6
       - **Maximum Delta S per Pass**: 0.02
     - Click the **HPC and Analysis Options** button
       - Click the **Add** button on the **HPC and Analysis Options** window
     - **Analysis configuration window**
       - **Configuration name**: training
       - **Use Automatic Settings**: checked
       - **Machine details**: Local machine
       - Click the **Add Machine to the list** button
       - Edit number of cores according to available hardware
       - Click the **Ok** button
     - Click the **Make Active** button on the **HPC and Analysis Options** window
     - Click the **OK** button
     - Click the **OK** button on Driven Solution Setup window

2. Save Project
   - Select the menu item **File > Save**
• Analyze Design
  • Select the menu item **HFSS > Analyze All**

• Create Current Plot
  • Select the menu item **Edit > Select > Objects**
  • Select the menu item **Edit > Select > By Name**
    – Select the object: **reflector_1**
    – Click the **OK** button
  • Select the menu item **HFSS > Fields > Plot IE Surface Fields > J > Mag_J**
    – Click the **Done** button

• Create Field Overlay
  • From the model tree expand Planes and select **Global:YZ**
  • Select the menu item **HFSS > Fields > Plot Fields > E > Mag_E**
  • Create Field Plot Window
    – Click the **Done** button
  • To modify the attributes of a field plot:
Animate solved fields

Animate Current Plot and Field Overlay simultaneously
- Select the menu item HFSS > Fields > Modify Plot Attributes
- Select J Fields or E Fields folders to change scale to from Linear to Log
- Select the menu item HFSS > Fields > Animate

- In the Project Manager window, click on Field Overlays
- Click the Close button on Animation window to stop animation

This part uses hybrid solver that includes two-way influence between the horn and the reflector. In the example, we reduced the size of the reflector for faster solution. Hybrid solver uses FEM (finite element method) in the volume inside FEBI boundary and MoM (method of moments) for IE Regions.
Plot Far Field

- **Create a Radiation Setup**
  - Select the menu item **HFSS-IE > Radiation > Insert Far Field Setup > Infinite Sphere**
    - Infinite Sphere Tab
      - Name: 3D
      - Phi: (Start: 0, Stop: 360, Step Size: 2)
      - Theta: (Start: 0, Stop: 180, Step Size: 1)
    - Click the OK button

- **Create 3D Far Field Pattern**
  - Select the menu item **HFSS > Results > Create Far Fields Report > 3D Polar Plot**
    - Solution: **Setup1: LastAdaptive**
    - Geometry: 3D
    - Primary Sweep: Phi
    - Secondary Sweep: Theta
    - Category: Directivity
    - Quantity: DirTotal
    - Function: dB
    - Click the New Report button
  - Click the Close button
Part 5: Placement study with Mesh Reuse

• Parametric Sweep of distance between horn and reflector
  • We will now complete the creation of the parametric project using the defined variable for coordinate system to vary the distance between the horn and the reflector in order to study how distance affects Directivity.

• Create Parametric Sweep
  • Select the menu item HFSS > Optimetrics Analysis > Add Parametric...
    - Click the Add button
      • Variable: offset
      • Select Linear Step
        – Start: 0 in
        – Stop: 1 in
        – Step: 0.5 in
    • Click the Add>> button
    • Click the OK button to close Add/Edit Sweep window
  - Click Calculations tab
    • Click the Setup Calculations button, Trace tab
      – Report Type: Far Fields
      – Solution: Setup1 : LastAdaptive
      – Geometry: 3D
      – Category: Directivity
      – Quantity: DirTotal
      – Function: dB

• Continue on next page
Parametric sweep setup

• Create Parametric Sweep (continued)
  • Click the Calculation Range tab of Add/Edit Calculation window
    • Theta: 0deg
    • Phi: 0deg
    • Freq: 10GHz
    – Click the Add Calculation button
    – Click the Done button to close Add/Edit Calculation window
  • Click Options tab of Setup Sweep Analysis window
    – Save Fields And Mesh:  Checked
    – Copy geometrically equivalent meshes:  Checked
  • Click the OK button

• Change reference coordinate system for Infinite Sphere setup
  • In Project Manager window, expand Radiation line
  • Double click on 3D infinite sphere
  – Click on Coordinate System tab
    • Check Use local coordinate system radio button
  • Click the OK button

Note1. Checking “Copy geometrically equivalent meshes” option enables mesh re-use for different parametric variations.

Note2. When plotting Far Field, it is better to use Coordinate System with origin close to the phase center of a resulting antenna. In case of reflector this point should be near the focus point of the reflector.
Parametric sweep results

- **Analyze Parametric Sweep**
  - In Project Manager window, expand Optimetrics line
  - Rightclick on ParametricSetup1
    - select Analyze

- **View Results of Parametric Sweep**
  - In Project Manager window, expand Optimetrics line
  - Rightclick on ParametricSetup1
    - select View Analysis Results
    - New window displays Calculations added to Parametric sweep vs. swept variable
    - Click the Close button

- **View Profiles of Parametric Sweep run**
  - In Project Manager window, expand Analysis line
  - Rightclick on Setup1
    - select Profile
  - Design Variation: click on the box with 3 dots
    - Uncheck “Use nominal design”
      - Select 0.5in
    - Click the OK button
  - Scroll up and down to review the Profile
    - Note mesh re-use for this parametric variation

<table>
<thead>
<tr>
<th>Mesh Assembler</th>
<th>00.00.01</th>
<th>00.00.01</th>
<th>331.1</th>
<th>6137.4</th>
<th>9037 lads</th>
</tr>
</thead>
</table>

Pre-solved mesh data was obtained from another geometrically equivalent design variation.
Horn-Fed Reflector Antenna

- **Overlay 3D Far Field Pattern and geometry**
  - Select the menu item **HFSS > Fields > Plot Fields > Radiation Fields**
    - Visible: **Checked**; Transparency: **0.7**; Scale: **0.8**
    - Click the **Apply** button
    - Click the **Close** button
  - Select the menu item **Window > 3 Reflector – HFSSDesign2 – Modeler** to return to modeler window

- **Animate Parametric variations**
  - Select the menu item **HFSS > Fields > Animate**
  - Click the **New** button
    - Swept variable: **offset**, select all values
  - Click the **Ok** button to start animation
  - Click the **Close** button on **Animation** window to stop animation

- **Summary**
  - For this example, we used 3D components that was created in Modelling Workshops.
  - The first two parts of this example shows how to analyze horn fed antenna using one-way data link approximation. For this method, we used the reflector with 13in radius. We compared Physical Optics and Integral Equation solutions.
  - The last two parts of the examples show the settings for strict, two-way link hybrid method of solving horn fed reflector. Since this rigorous solution requires more compute resources, we used the reflector with 6in radius. Mesh assembly and re-use mesh features were used to solve the hybrid design and parametric variations.