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Introduction

In this tutorial, a single-mode cavity resonator will be constructed and
analyzed using the HFSS simulation software. This tutorial is designed for first
time users and is intended to introduce commonly used commands and
techniques. By the end of this tutorial the user should be able to:

General navigation of software menus, toolbars, and quick keys.
Variable assignment.
Overview of commands used to create complex geometric models.

Analysis Setup.

v
v
v
v Proper assignment of sources and boundaries.
v
v Report creation and options.

v

Optimetrics setup and analysis.



Getting Started

From the Project Manager window, right-click the project file and select Save
As from the submenu. Name the file “TE10_cavity” and Click Save.
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Project Yariables ...
Datasets...
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To begin working with geometries, you must insert an HFSS design. Right-
Click the project file and select Insert -> Insert HFSS Design from the menu.

» ﬁ Insert HFSS Design

Insert Documentation File ...

Close
n Save Chrl+5
Save As...

Project Wariables ...
Datasets,..

Remove Unused Definitions ...

Always create a personal folder to store all HFSS projects. You may
find you do not have access rights to some portions of the hard drive.
This will also allow the user to quickly backup/copy data from projects.

> Note:



Design Variables

HFSS relies on variables for parameterization/optimization within the project.
Variables also hold the following benefits:

v Fixed Ratios (length, width, height) are easily maintained using variables.

v Optimetrics use variables to optimize the design according to user-defined

criteria.

v All dimensions can be quickly changed in one window as opposed to altering
each object individually.

Click the HFSS heading and select Design Properties at the bottom of the

menu.
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Design Variables

A table will be displayed allowing the user to add the variables of the project.
Click Add to enter the variables. Be sure to enter units immediately following the
value with no space between. Enter all variables shown below:

x|
Local ¥ arisbles |
i+ Walue i~ Optimization " Tuning " Sensitivity " Statistics
Mame I Walue I Unit I Description | Read-anly | Hidden I
|_cavity B2.789 cm I_ I_
W_wg 24,763 cm — —
g 12,3825 cm — —
|_feed W g I_ I_
r_iriz R3634 cm I_ I_
r_choke 2.4925 cm I_ I_
h_choke 25.4 cm — —
1_sample 1.27 cm — —
IV Show Hidden
Add... Femove
ak Cancel

Click OK to complete.

> Note:

Creating variables before defining the structure will allow
the user to build the geometry much faster than using a
fixed coordinate system.




Building the Model

With all variables defined, the model can be quickly constructed. All
geometries in this tutorial are created using the 3D modeler toolbar. The toolbar
is illustrated below:

N YIDN OO0 S RA0A S B e & ur v|f [~

We will begin by constructing the primary structure. This consists of a
waveguide feed and a resonant cavity. Select Draw Box (from the toolbar) and
use the mouse to select 3 arbitrary points within the drawing area. A box will
display properties that will be entered as shown below:

Properties: TE1D_cavity - HFSSModell - 3D Modeler 5[

Cormmand | Attribute |

Mame | Walue | LUnit | D escription |
Cormmand CreateBox
N Coordinate System | Glabal
N Pozition Lcavity/2] . [w_wal2] . {h_wal2)
[ [wsiee | cavity + |_feed
: Size W

[~ Show Hidden

ak I Cancel

Under the Attribute tab and enter the following:



Properties: TE10_cavity - HFSSModell - 3D Modeler ﬂ

Command  Attribute |

Mame | Walue | Unit | Degcription | Fead-only |
| [Name cavity_wg -
L |
Solve Inside v -
[ Orientation Glabal -
| Modsl - i
N Dizplay Wireframe [ -
| Color Edi i
N Transparent 049 I_

™ Show Hidden

] I Cancel

Building the Model
Click OK when complete. The structure is depicted below:

Next, we will build the “choke”. We will make use of the duplicate command to
construct it in two steps. Select Draw Cylinder and arbitrarily position the object
in the drawing window. Enter the following properties:



Properties: TE1D_cavity - HFSSModell - 3D Modeler

CreateCylinder
Global

Ocm , Ocm, h_wg/2
i

1_chaoke

h_choke




Building the Model

Under the Attribute tab, enter the following:

Properties: TELOD_cavity - HF5SSModell - 3D Modeler il

Command  Attibute |

Mame | Walue | Unit | Description | Fead-only |
Marne choke -
M aterial air | -
| Solve Inside v -
| Orientation Global -
[ Model [ -
| Drisplay ‘wireframe I_ I_
| color Edit -
| Transparent 049 I_

[~ Show Hidden

ak I Cancel |

Click OK when complete. Step one of the “choke” is complete and should
appear as follows:




Building the Model

The next command is very useful when building symmetrical objects. Select
the newly created “choke” by clicking the object directly. Right-click the modeling
area and select Edit -> Duplicate -> Around Axis.

o

Al Object Faces

Y

|7 Seleck Objects ]
Seleck Faces F
[exk Behind E

Measure

View

Paste Chrl+y
E - "B Assign Material...
> Delete Dl .
Assign Boundary
Properties... Assign Excikation
Assign Mesh Operation
Arrange 4
Duplicate q g Slong Line

;S Around Axis. ..

5 3|L I¥irror

Scale

Surface
| Boolean 4
o
Al Sweep L4

‘ Delete Last Operation

In the property window, enter the following:

Duplicate Around Axis

Bis: w Oy OZ

Angle: |1 an - l I deg ¥ l

Tatal number: |2 :II

(] I Cancel |
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Building the Model

The result of the Duplicate operation is shown below:

- Note:

Make sure that all materials, up to this point,have been defined
as air.

At this point, all three objects are considered as separate entities. Using the

selection button on the toolbar, select all 3 objects OK.
From the toolbar, select 3D Modeler -> Boolean -> Unite.
i Import.. . | ST | == &5
N
: [w Group Objecks By Material : |:| | s | [=1 |i_ i |
¥ nfssign Makerial, ..
Mowemenk Mode L4
igrid Plane L4
Snap Mode. ..
Mews Object Type » a4
Zoordinate Sysktem L4
Lisk r
Surface 3
T [y subkract...
— Inkterseck
Measure ¥ [0 sSplik...

Separate Bodies

Eenerake Hisbary
Delete Last Operation I ]
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Building the Model

All three objects have now been united. This operation unites the “choke”
structure with the “cavity” making the volume common.

e=>

In the next step, the “sample” structure is created. A custom material, with a
complex dielectric constant, will be defined. Begin by selecting Draw Cylinder
from the 3D toolbar. From the property window, select the following:

i Properties: TE10_cavity - HFSSModell - 3D Modeler ﬂ

Command | Attribute I

Mame Walue Lnit Drescription
I [ urit | |

Command CreateCylinder
| Coordinate System | Global

| Center Pogition Ocm , Ocm , -(h_wa/Z2]
- Axis z

Fadius 1_sample

Height h_wg

[~ Show Hidden

()8 I Cancel
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Building the Model

Under the Attribute tab select Material and click Add Material enter “sample”
for the name. Now create a custom material by selecting Material and enter the
following:

¥iew / Edit Material x|

Material Mame
Isample

Froperties of the Materials Matenall

— Filter Properties by
MName Type Walue Units I ansoft Products
Relative Permittivity Simple | 4.5 &0 products
| Relative Permeability Simple 1 [AHF5S
N Bulk Conductivity Simple ] Siemens/m
| Dielectric Lozs Tangent Simple [IN]
N Magnetic Loss Tangent Simple ]
| ki agretic S aturation Simple i] Gauss
] Lande G Factor Simple 2
DeltaH Simple i] Oe

Select Anzaft Product

&l products
[ JHFSS

Walidate Maow |

Set Frequency Dependency .

The material is defined as complex by defining the dielectric loss
tangent. See help for further explanation of complex material
assignment.

—

13



Building the Model

The final structure to add to the geometry is the “iris”. The iris allows
microwave energy to be coupled into the cavity. The geometry and size of the iris
affects the resonant characteristics of the cavity. This structure will be built in two
steps. First, a plate is created, separating the waveguide and cavity. Next, the
circular “iris” will be placed on the plate and subtracted. This operation will create
a hole in the plate and the radius of this “iris” will be optimized for maximum
energy transfer.

The two dimensional plate is placed in the yz-plane. Change the drawing
orientation by selecting yz from the toolbar as shown below:

B St B s ]|
| a A.-rlx‘r j"InPIane
y ]

[~ =] [ |[%

Properties: TELD_cavity - HFSSModell - 3D Modeler x|

Cormrnarnd I Attribute |

Mame “alues it Description
| | | |

Command CreateR ectangle

Coordinate System | Global

Position |_cavitp 2 | -w_wad2 | -h_wgs2
Az E

Size W

ZSize h_wa

™ Show Hidden

(5].8 I Cancel I

Select the Attribute tab and enter the following:

Properties: TE10_cavity - HFSSModell - 3D Modeler x|

Command  Attribute I

Name | Walue | Unit I Description I Read-only |

Name divider

B Orientation Global

| Madel =i

| Diizplay "wireframe I_

[ Color Edi |
: Tranzparent 038 I

1

™ Show Hidden

Cancel

Click OK when complete.
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Building the Model

Since the plate is a two dimensional object, a material definition is not
possible. Now create the “iris” by selecting Draw Circle from the toolbar and enter

the following:

i Properties: TE10_cavity - HFSSModell - 3D Modeler x|

© Command | atrbute |

Name Yalue Unit Descriptian
I [ uni | I

Command CreateCircle

Coordinate System | Global

I Center Position |_cavitys2 , Dcm , Dcm
iz ®
Radius 1_itis

[™ Show Hidden

Cancel |

Under the Attribute tab, enter:

fl Properties: TE10_cavity - HF5SModell - 3D Modeler 5[

f Command Attmbulel

Name I Walue | Unit I Description | Read-anly I
Name ifis -
] Orientation Global I_
[ [bhodel il r
I Display Wwireframe |_ |_
| Color Edit | |_
: Transparent .5 | -

[™ Show Hidden

Cancel |

Click OK when complete.
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Building the Model

In order to properly create the “iris”, the “iris” must be subtracted from the
plate. First, select both objects. Use the Object selection button on the toolbar as
shown below:

58606 = x
EI @IIObjEEt j I ame:

. Cavity
'g M Select by name
= LT
zample

Ok I Cancel |

Select both the “divider” and the “iris” and click OK. From the toolbar select
3D Modeler -> Boolean -> Subfract.

30 Modeler  HFSS  Tools  window Help

© e b e S S
| Bport. | o &z =
7 IT Group Objects By Material ; |EI | i | [=] |+.— & ‘
1 4 iission Makerial. .,

Movernent Mode 4

Grid Plane 4

Snap Mode. ..

Mew Ohiject Tyvpe 4

Coordinate System 4

List r

Surface 4

Boolean

Units. ..

Intersect
Measure * [ Split...

o te Bodi
Generate Histary: SRl Pre

Delete Last Operation |
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Building the Model

Subtract the “iris” area from the “divider area” as follows:

CE x|
Blank Parts - Toal Parts
divider iris
> |
e |

I Clone tool objects before sublracting

aK I Cancel I Help |

The “iris” should now resemble the figure below:

A complete view of the structure is shown below:

17



Boundary Assignment

Now that the geometry is complete, the user must assign boundary conditions
to properly analyze the structure. All external surfaces are defined as Perfect
Electric Conductors (PEC) to simulate ideal conductors. Start by using the
selection button in the Modeler toolbar.

Note: Make sure that Face is selected in the selection edit window.

Select the “cavity_wg” object and highlight the following faces:

Depending on the order of construction, the user may find that
his/her object does not contain Face12. In this case Face12 is the
located furthest from the origin along the x-axis and is in the yz
plane. Throughout this tutorial, Face12 will refer to this face.

- Warning:

Select Face x|

Object name: Face ID:
Facell

cavity g

divider Facell

zample

] I Cancel

18



Notice that “Face12” has not been highlighted. The excitation source will be
defined in the next section. This face is used for the source.

19



Boundary Assignment
From the project tree, Right-Click Boundaries->Assign->Perfect E:

—_— e

= TE10_cavity - Be gmile ol
; T N reateCylindsr
E--ﬁﬁ HF55koden E| s Nat Assigned
€7 Model {E-E? divider
....EW N
- %3 Excita =
EF Mesh List. . Perfeck H...
‘ﬁl Analy: Delete Al Finite Conduckivity:. ..
ﬁ O pkirm Yisualization. .. Impedance. ..
-~} Fesul Repriaritize. .. Layered Impedance. ..
ftH] Part F Radiation,..
i i PML Setup ‘Wizard. .. RACIEHE
[i Field L Symmekry. ..
';' R adiation Masker. ..
[#1-[_] Definitions Slave...
Lurnped RLC. ..

Name the boundary “PEC1”. Follow the same procedure and assign the
“divider” as “PECZ2”. All surfaces of the resonating geometry are now defined.

- Note:

Check the objects and verify the material as “air”.

20



Source Assignment

In this example, a wave port will be implemented. The excitation is assigned
as a TEq o mode implying that the electric field vector is positioned vertically and
normal to the axis of the waveguide.

Begin by selecting a face for wave port assignment. Make the following
selection:

x|
Object name: Face ID:
cavity wg Facel0
divider Facell
zample
Face3s
Faced?
Faceds
Faced?
Face?
Faced
Faced

0k I Cancel |

Right-Click Excitation->Assign->WavelPort.

=80 TE10 cavy e et
E@ HFS 5k odell E'! Mak Assigned
- &7 Model L £ divider
|_:_|ﬂ Boundaries -4 air
P Pt =-€P cavity_wg
T PelE? ) CreateBox
&w [ T ) I P T IO

Bssign Wave Park, ..

_____ ﬁ Anal Edit Impedance Mulk

..... ﬁ |:||:|t|| I:iSt' oo

_____ = Res Delete All

..... [ Port Wisualization. ..
Fielc Repriaritize. ..

Lumped Part, ..

Incident Wave. ..
Yolbage...
Currenk...

Magnekic Bias...

Leave the default name as “WavePort 1”.
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Source Assignment

Click the modes tab and select New Line... from the drop down menu.

|
|V ave Port : Modes |
Number of Modes: |1 Update |
tMode |ntegration Line I Characteriztic Imp. [£o]
Maone LI

Mone

[~ Polarize E Field

1
|
| Use Defaults |
I
|

< Back I Mest = I Cancel |

Position the mouse over face12 and let the pointer snap to the bottom center
of the plane. Left-Click to define the vector origin. Position the mouse over the
top center of face12 and Left-Click to define the endpoint of the vector. Click
Next and Finish to complete.

The wave port should resemble the following:

22



Solution Setup

HFSS requires a solution setup in order to analyze the structure. From the
project tree, Right-Click Analysis->Add Solution Setup

ml P_D ' Analyze

Eg Fie Reewert bo Initial Mesh
Rz )

H Apply Mesh Gperations

1177 Dafiit

The cavity is expected to resonate at a frequency of 915MHz. Enter this as
the solution frequency. Set Maximum Number of Passes to 20 and Delta S to
.02.

x
General |.-’-‘u:|vanceu:|| Ports I Defaultsl

Solution Frequency: |9'|5 IMHz ﬂ

[ Saolve Parts Only

—Adaptive Solutions

b aximum Mumber of Pazzes: |2E|

M axirmum Delta S Per Pass: noz2
Usze Defaults |
Ok I Cancel

If simulation time is excessive, the user can lessen the computational
load by allowing Maximum Delta S >= .05.

- Note:
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Solution Setup

In order to view the spectrum of S1 parameter, HFSS must sweep through a
range of frequencies. According to the design, the point of resonance should
occur at 915MHz. This will be the center point of the sweep and a tolerance of */.
65MHz will determine the sweep range. If desired, the user can reanalyze this
sweep with less tolerance once the resonant point has been identified. Right-
Click Setupi -> Add Sweep from the window.

-1 Defi

: ﬂ’ Analysiz | | |

Opti Rename

Res > Delete

Properties. ..

ritig  Analyze
Revert to Initial Mesh
Apply Mesh Operations

rafile
Convergence

[attix Data

Enter the following parameters in the Edit Sweep window:

HEdit Sweep

i
[

—Sweep Tupe
7 Discrete

* Fast
" Interpolating

Evrar Teleranze: |05 (5

I &z Soluticrs |2D

DC Extrapolation Options
[ Ewtrapolate to DC

¥ | Srap Magnitude to

Snapping T alerance

Fimimurm Salved Frequency IU-1 GHz =

L =

ID.D‘I

Time Domain Calculation... |

Frequency

—Frequency Setup I
Type: Im
Start |35U IMHZ 'I Dizplay »» |
Stop ISSU IMHZ vI
Count |1 oo
¥ 5ave Fields
QK. I Cancel

Click OK when finished.
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Solution Setup

Before starting the Analysis, it is a good idea to run the Validation Checker to
verify that the structure and all options have been properly applied. From the
toolbar select HFSS->Validation Check.

¥alidation Check: TEL1D_cavity - HFS5SModell il
« 30 Model
y RISl ¥ Boundaries and Excitations

¥ Mesh Dperations

Walidation Check completed. o fnalysis Setup
[ Optimetrics

| ¥ Radiation

[ et | Close

If errors are present, please correct them before continuing. The
results should appear as those in the above figure.

- Note:

From the toolbar select HFSS -= Analyze.

|HFSS Tools  Window Help

Solution Type. ..

]' Lisk...

= g walidation Check...
¥ B Edit potes...

b4
i 30 Model Editar
ar
ir
k Excitations

Boundaries

Mesh Operations
Analysis Setup

* v v v ¥

Optimekrics Analysis

ﬂ Analyze
Results L4
Fields 4
Radiation L4

Boundary Display {Solver Yiew)

Design Propetties. ..

Depending on the machine, the analysis can take from 5-35 minutes.
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Create Reports

After Analysis, a report must be created to view the desired results from the
simulation. From the toolbar select HFSS->Results->Create Report.

HFSS Tools  Window Help
Solution Type...

" E List...

- g validation Check...

]@ Edit MNokes. .,

RN

[
LG ’%"%H“"%

3D Model Editor

Boundaries

)
C
T
T

Excitations

Mesh Operations

Analysis Setup

Optimetrics Analysis

* v v oy v

* Analyze

Results
Fields
Radiation

L4 Solution Data...

Create Repart...

Qukput Yariables. ..

Boundary Display (Solver Wiew)

Design Properties...

Update Reparts
Open Al Reparts

Browse Solutions. ..
Clean Up Solutions. ..

Import Solutions...

The S-parameter plot will display the reflection coefficient vs. frequency. The
resonant frequency can be visually determined from the plot. Enter the following:

Create Repork il

Target Design: IHFSSModeI‘I
Report Tupe: IMUdaI 5 Parameters j

Display Type: IHectanguIar Plat j

o]

I

Canicel |
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Create Reports

Many options are available from this window. For now, Highlight the variables
shown below and click Add Trace. Leave all remaining options as default.

1 Traces

P | v [ v-anis
|
H 1 |Freq dBIS [ avePort] W avePort] )] 1
i —Context Sweepsl " v |
Design: [HFS Shodell =l
Categon,: Cuantity:
Salbicn ISE[L‘F|1 - Sweepl = Wariables S avelPart]

Drornain: ISweep

TDR Options...

Output Variables. ..

Output W ariables

' Parameter
Z Parameter
WEWH
Gamma
Port Za

Add Trace I

Set Temminations. .. |

g [m] ]

Add BlankTrace |
Femave Trace |
Femove &ll Traces |

Feplace Trace |

Function:

ang
arg_rad

im
mag
re

Click Done to complete. The following plot is displayed:

25 Jan 2004 Ansoft Corporation 174716
Y Plot 2
HFS Shdodel 1
000

— -5.00
=
t
S
%
=
=
;. i
E -100n
S
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=
H
&
& d
= -15.00 V

-20.00

£40.00 2E0.00 £20.00 a00.00 92000 94000 QE0.00 as0.00
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Create Reports

Inspection of the previous figure suggests that the resonant frequency is
approximately 915MHz. Use the zoom feature by Right-Clicking the plot area and
select Zoom [n. Place a window around the peak. Right-Click the plot area and
select Datta Marker . Select the lowest point to determine the resonant frequency.
The plot is shown below:

25 Jan 2004 Ansoft Corporation 17:49:41
HY Plot 2
HFSSModel 1

. 5
=
\/

-17.25

dB{S{WavePort1,WavePort1))

-17.50

-17.75
91300 914.00 915.00 916.00 917.00

Freq [MHz]
&[x1= 914.54MHz
1= -17.08

The resolution in this analysis is a limiting factor. Resolution is
increased by narrowing the sweep range and keep the count size
constant. The user can also explore other types of sweeps (see Ansoft
help).

Note:
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Optimetrics Analysis

In HFSS the optimetric tool is used to optimize variables according to user
defined input. Variables are optimized and this could save the designer hours of

trial and error using empirical and/or experimental approach. In this tutorial,

all

variables were given to the user. Let us assume, as a designer, that the only
adjustable variable in the design is the “iris”. All other values are fixed. We will
optimize the radius for maximum power transfer, at a frequency of 915MHz, into

the cavity. According to experimental data, the optimum radius should

lie

between 5-6cm. Parametric analysis will allow calculation of fields for different

values of “r_iris”.
From the project tree select Optimetrics -> Add -> Paramefric.

© e DEWR | | |
ﬁ E.ararnetr'ic...
- 4 : —
E Fesul }fg Tuning. .. @ Opkimization, ..
El@ Part F Wiews Analysis Result, . 5 Sensitivity...
Ei Field Overlays Iy Statistical...
52 Radistion 1

Select “r_iris” as the variable. The radius will begin at 5cm and end at 6cm
with a step size of .2cm. Click Add and OK when finished.

Setup Sweep Analy: il

Swizep Definitions | Table I Genelall Calculatinnsl

I Sync ﬂl \-"ariablel Descriptionl | [ add. |
Add/Edit Sweep Dialog x|
. = Variablel Description
Y ariable Ir_|r|$ 'I — -
1_irig Linear Step from Bem to Bom,

" Single value
& Linear step
" Limear count Add >> |
" Decade count
" Dctave count Update 5>

" Exponential count

[ [

[elet
Start: |5 ICI‘ﬂ j —
Stop: |E Ic:m j
N Step: IEI.2 Icm j ok I Cancel
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Optimetrics Analysis

From the Calculations tab, select Edit Calculation.

Setup Sweep Analysis

Sweep Definitionsl Table I General Calculations I

Salution

Calculation

&dd

Delete Edit Calculation...| Edit Cal. Range...|

ak. | Cancel |

We will examine the S11 parameters so enter the following power expression:

| Output Yariables

— Dutput % ariable:

Rl riainm

Expression

Mame: Ima:-cimum Add | Update I Delete
|| Expression: mag (5w avePort] WavePort1))
r— Calculation
Inzert Quantity Into E xpression
Category: Quantity: Function:
Design: - Y ariables ]
. I J O utput Variables
HTE}II:;DD;F IModaI S Parameters j Y Parameter
' Z Parameter
S olution; ISetup1 : Lastidaptive j \éil\:nvr?a
Port Zo

— Function

Inzert Function |
=

Iabs

Terminations [ohmz)

S0 ot s

Set Teminations... |
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Optimetrics Analysis

Name the expression “maximum”. Click Add and Done when complete. Under
the calculation edit window, select “maximum” from the drop down menu as
shown below:

Setup Sweep Analysis ﬂ

Sweep Definitinnsl T able I General Calculations I

Solution Calculation I

Setupl : Lastidaptive

Add Delete Edit Calculation...| Edit Cal. Range...|

Ok I Cancel |

Click OK when complete. From the project tree, right-click Optimetrics -=
Analyze. Depending on the machine, analysis can take from 5 minutes to 1 hour.

T
Eﬁ Optimetrics
. Fename

Resultz
a E > Delete

EEl Pt Fieh
. ElE| W Properties. .,

] Wiew Bnalvsis Result.. .
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Optimetrics Analysis

With analysis complete, Right-Click Optimetrics -> View Analysis Result and
select plot in the window. You should see the following results.

31 Jan 2004 Ansoft Corporation 21:38:44

07

0.5

0.4

0.3

0.2

stup1 : LastAdaptive : maximum: Freq(Single value at 915MH

01
50.00 52.00 54.00 56.00 58.00 60.00
r_iris [mm]

The above figure displays Sq1 vs. iris radius. We find that minimum reflection
occurs between 5.2cm and 5.4cm. With this information, we can now re-analyze
the iris variable defined from 5.2cm to 5.4cm. Set the step size to .05cm. Follow
all previous step and re-analyze with the new settings.

il Add,/Edit Sweep Dialog x|
) — Wariable | D escription |
ariable II_III:S 'I — -
_iris Linear Step from 5.2cm to 5. 4cm, step=0.05cm

i~ Single walue
% Linear step

" Linear count Add >> |
= Decade count
" Octave count Update > |

= Exponential count

Start: |5-2 Ic:m 'I &I
Stop: |5.4 Ic:m 'I
Step: [0.05 [em =1 ok | Cancel |
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Optimetrics Analysis

When complete, view the S¢4 parameter from the plot. The results are shown

below:

31 .Jan 2004

Ansoft Corporation

22:08:28

stup1 : LastAdaptive : maximum: Freq(Single value at 915MH

[
52.00

52.50

53.00

r_iris [mm]

53.5

According to the graph, minimum reflection occurs at approximately 5.3cm.
This should produce optimal power transfer into the cavity. With this information,
redefine the “r_iris” variable under HFSS -> Design Variables. Follow all
previously completed steps in this tutorial and rerun the Analysis with the new
variable definition. Create Reports and generate S11 plot. What can you
determine from the new plot ?

31 Jan 2004

Ansoft Corporation

XY Plot1
HFSSModell

22:19:14

-10.00

-15.00

dB(S(WavePort1,WavePort1))

-20.00

-25.00

840

Frag [MHz]
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Optimetrics Analysis

Comparing both S11 plots should verify results. See the figures below:

Original : r_iris = 5.3634cm

245 Jan 2004 Ansoft Corporation 17 :45:41
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Optimized : r_iris = 5.3cm
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Optimetrics Analysis

In addition to the S11 plots, the E-field is plotted along the length of the cavity.
Note the maximum Electric Field in the plots below:

Before Optimization (5.363cm)

E Field[¥/m]
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After Optimization (5.3cm)
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Material Conductivity

In this section, the PEC material will be changed to Aluminum. Results
obtained should be more realistic for obvious reasons. From the toolbar select
Face from the select object bar.

Select all faces belonging to “cavity wg” as shown below:

Select Face x|

Object name: Face D

cavity wg
divider
zample

ak I Cancel |

From the Project Manager window, right-click Boundaries -> Assign -> Finite
Conductivity.

[ ™
Perfect E...
Perfect H...

m

Finite Conduckivity. ..

----- BEF Me: Visualization, .. Impedance. ..
EEI---IEJ Anz Repriaritize. . . Lavered Impedance. ..

Eﬂ"'ﬁ Opt Radiation. .,
- PMLSetup Wizard... = t

Swmmekry. .,
Master...

Slave, .,

Lumped RLC...
i |
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Material Conductivity

From the Finite Conductivity Boundary box, select Aluminum and click OK.

Finite Conductivity Boundary x|

Mame: IFiniteEDnd'l

— Parameters

[Earduistivity IEBDDDDDD Siemens/m

Fermneability: |1

v Use Material | alurninum I

[ Infinite Ground Plane

Uze Defaults

il

Ok Cancel |

Save your work. Analyze the structure as performed with the PEC structure.
When complete, plot the S14 parameter. The results are displayed below:

27 Mar 2004 Ansoft Corporation 20:47:07 ¥1—)
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Material Conductivity

The E-field plot for Aluminum is given below:

E Field[¥/n]

 S4EGe+E835
. Y43 e+EES
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Optimetrics should be used from this point to re-optimize the iris for
maximum power transfer. This will be left as an exercise for the user.
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Quality Factor

In order to determine the Quality Factor of the circuit, the solution type must
be changed to Eigenmode. From the HFSS toolbar select:

|HFSS Tools  Windmw  Help

Solution Type. .. |

Solution Type: TE1O_cavity 033104 q - ll

" Diriven Modal
" Driven Terminal

¥ Eigenmode

QK I Cancel

Click OK when complete.
From the Project Manager window, Create a solution setup as follows:

[#-4 Plane
; Paint

EF Mesh Operations

ﬁﬂ; g Add Solution Setup. ..
Re  Lst..

[T Pa ‘ Analyze

[l‘i Fie Revert ko Initial [Mesh
Rz

Apply Mesh Operations

Right-click Analysis -> Add Solution Setup.

= ﬁ Analyzis
> i

S FREEL Properties...
7 Definitian:
Analyze

Revert to [nitial Mesh
Apply Mesh Operations

HE
Convergence

Setupl

Eigenmode Data

n

Right-click Setupi -> Properties.
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Quality Factor

Set Minimum Frequency = 910 MHz. Click OK when complete.

Solution Setup x|

General | Advanced I Defaults I

Mirirnum Frequency: 310 IMHZ j

Mumber of Modes: I'I

—Adaptive Solutions

b amimunn Mumber of Pazses: I2D
taximum Delta Fregquency Per Pass: I1 0 %

[ Converge on Fieal Frequency Only

Uze Defauls |

ak I Cancel |

The eigenmode solution will find the cavity resonance and the Q of the cavity.
Run the Validation Check as in the previous example to verify correct setup. Run
the Analysis. When complete, right-click Setupi-> EigenmodeData.

Elﬁ Analysis ” | |

g Optn_ Rename
I Fesu > Delete

rﬂ Field Eroperties...
—7 Definition

fnalyze
Rewvert to Initial Mesh

Apply Mesh Gperations

]: Prafile

Convergence

Setupl
20
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Quality Factor

The resonant frequency and quality factor are given as shown below:

=
Design Yariation; |s='5.3cm' 1_gample="1.27cm’ w_wg="24, 7E3cm’ _I
Simnulation: ISetup‘I j ILastﬂ.daptive j |J

Eonvergencel Profile  Eigenmode Data I

Solved Modes

Frequency [GHz)

tade 1

Cloze

The Eigenmode solution found the resonant frequency at 917MHz. This

calculation could be made more accurate by decreasing the
Frequency Per Pass within the analysis setup.

Maximum Delta
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Conclusion

This tutorial should give the user an introduction to HFSS and a few of the
available features. The user should now be able to begin designing and
optimizing structures on his/her own.
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