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摘要 

该Demonstration将通过对设计实例讲解和练习，使读者可以了解到 DxD-Pads2007.4 流程的基本使用,如何

设置和使用。从而熟悉软件应用的环境及能学习如何完成自己的设计项目。 

本书分为五个主要部分：原理图工具的使用，原理图数据到PCB 设计数据的生成和更改，PCB 工具的使用、

生产数据检查和生产数据输出。 
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原理图工具DxDesigner的介绍及应用 

1.> DxDesigner设计软件介绍 

 

首先从桌面图标中 调用Dashboard  

 

在Dashboard Folders 面板中,选择Toolboxes > Board-level (PCB) Design. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
如下图，可通过拖放的方式把常用的工具放到快捷面板中.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
双击DxDesigner图标, 

 

 
 

启动 DxDesigner. 

界面如图所示: 
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2.> 基本操作方法简介 

在开始设计项目之前我们先介绍一些常用的快捷操作方式. 

2.1 鼠标功能介绍 

鼠标左键单击  : 选择对象 

鼠标右键单击  : 根据所选对象，列出可执行的操作 

鼠标中键单击  : 放大当前示图Zoom In 

Shift+鼠标中键  : 缩小当前示图Zoom Out 

注: 为了方便在后面的课程中应用鼠标命令，用下面缩写代表三种不同的鼠标操作: 

LMB:  鼠标左键(default) 
RMB:  鼠标右键 
MMB: 鼠标中键 

 
2.2 显示快捷方式:  

选择菜单Help>Show Bindings  

可以得到所有快捷键的列表 

 

 

 

 

 

 

 

 

 

 

 2.３ 笔划快捷方式:  

 

我们把划笔区域定义为9个格子，如下: 

 

按住相应的鼠标键(默认情况下是右键)，参考右上图的命令， 

可以“画出” 相应的命令。 例如：下图中使用相应的鼠标键画出“352”，可以执行相应的放大命令。 
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2.1 选择方式介绍 

选中单一物体 在目标上单击左键 

选中一组 按住左键进行框选; 

增加选择 Crtl+LMB, 增加选择到多选中 

取消选择 在空白处左键，取消所有选择 

从多选中取消一选择 Shift+LMB：点击多选中的物体 

 

 2.1.1 选择网络 select Net  

 
 
 2.1.2 选择网络分支 Select Net Branch 

 
 
 2.1.3 通过浏览器Navigator选择

symbol和nets 

 通过浏览器与原理图进行交互式选择，

可以加快查找/选择的

速度. 

 

 2.1.4 选择过滤

器勾选中表示该类属性物体能被选中 
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3.> 模板设置及创建一新的项目 

3.1 模板设置 

DxD2007的配置比之前的版本更加简单,减少了大量的配置文件,只需要如下两个文件即可: 

Expedition.prj : 只需要单一的项目配置文件  

DxDesigner.xml :用户设置文件 

  
把我们需要的.PRJ文件拷贝到 WIR目录下(WIR具体设置查看环境变量),具体结构如下: 

<WDIR\ \templates\dxdesigner\netlist\Template_training.prj 
 

3.2 Databook OCDB数据设置 

3.2.1 在windows中选择打开: Start > Control Panel > Administrative Tools > Data Sources (ODBC).  这将打
开 ODBC数据管理对话框. 

 
3.2.2 选择 User DSN 栏, 添加.MDB数据到 ODBC数据库中. 

 
3.2.3 选择 ADD, 确认 DxDClass 是否指向 C:\MGTraining\common\libraries\dxdatabook\DxDClass.mdb. 
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3.2 新建一项目 

3.2.1选择 Menu: File > New > Project 创建一新的项目 (也可在Dashboard中创建) 

 
>> 从Project Templates(模板)列表中选
择 

“Training_template” 
 
>> 在名字框中(Name)输入 “AMP”. 
注意在location栏中, “AMP” 自动显示
出来 
 
>> 从Layout Tool 工具下拉列表中选
择PADS 2007. 
 
 

注：A、什么是Prj文件？------ 可以用Text Editor 进行查看编辑。 

B、模板（*.prj）可以拷贝，放在系统wdir\templates目录下。这个例子中我们需要在环境变量中添加

c:\MGTraining\Common\Config  

 
在 DXDesigner中显示新的项目界面(如右图) 

 
3.2.2 创建/增加一个新的原理图. (Menu: File > New > Schematic.) 

（注：这是开始创建一个设计） 

3.2.3 从左边的Navigator 窗口中，展开设计和修改设计名为 

“amp1”RMB(右键) > Rename. 

 

 

 

 

 

 

 

 

3.2.4 更新原理图Schematic的标题栏(title).  Menu: Edit > Update Properties >Sheet. 

Border信息框将显示如下: 

 

3.2.5 取消所有的选择(选择原理图空白处). 

3.2.6 保存原理图当前状态 Menu: File > Backup. 
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4.> 项目的设置 Menu: Setup > Settings  

 
 

4.1  Project项中：指定项目配置文件,包括border,bus的定义，layout工具(pads2007)等等 

 4.1.1 Symbol Libraries:增加symbol库 

 

 指定symbol的路径，为包含sym的目录名 

 

Alias是指定该类symbol的名字 

 

Type包括3种类型,只读，可写， 

系统默认为megafile 

 

 

 

 4.1.2 Special Components:指定一些

特殊连接性器件。包括port in, offpage, pow等 

 
 4.1.3 Borders :指定版图，版框类型 
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4.2 Schematic Edit 项中：包括单位，格点，缩放等原理图的控制 

4.2.1 单位的定义  6.2.2 格点的设置;格点修改为0.05in 

 

 

 

 

 

 

 

 

 

4.2.3 缩放的方式定义，笔划按键定义 6.2.4 默认字体的定义 

 

 

 

 

 

 

 

 

 

 4.2.5 走线方式的定义  

  

 

 

 

 

 

 

 

 

 

 

 

4.3 Navigator 浏览器显示属性的设置 

 分别设置Block,Symbol,Net在浏览器中的显示方式 

 （使用默认的设置） 

 

4.4 Display 原理图中的显示模式及颜色定义 

 在这个设置中，可以定义背景，nets走线，symbol, 

字体等的显示颜色。 
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5.> 放置器件  

下面几步你将增加下面器件到原理图中: 

  [Amplifier OP215A.  ]     [Resistor RES-SMD1206-100K ](2 copies) 

   [Resistor RES-SMD1206-3K ]     [Capacitor CAP-SMD0603-100P] (2 copies) 

添加器件有两种方法，一种方法是通过View > Symbols 或图快捷图标  来放置symbol 

 
这种方法需要手工添加器件的信息，例如电阻的封装pkg_type,阻值value等信息。 

另外一种方式是使用DxDataBook，这里推荐使用DxDataBook增加器件，下面是详细的解释如何增加器件.. 

 

5.1 调用 DxDataBook.    (Menu: View > Other Windows > DxDataBook) 

 注：A、如果打开DxDataBook，在查找器件时报没有找到odbc数据，需要通过在 控制面板>Administrative 

Tools>Data Sources ODBC的User DSN中，添加Microsoft Access Driver(*.mdb)数据，数据指向 

\MGTraining\common\libraries\DxDatabook\DxDClass.mdb 

  B、在DxDataBook右键打开configure>open…，指向\MGTraining\common\libraries\master-DXD\DxDClass.DBC 

 

5.2 通过关闭Output窗口来放大DxDataBook 窗口,这样更方便浏览及操作 

5.3 查找器件OP215A: 

a. 从Databook界面中选择Library = “amplifier” .  

b. 指定Field = “DEVICE “ 

c. 设置 “Operator to” 为 “=” ； Value 输入 “OP215A” 来查找器件. 然后选择 “+”. 

d. 选择右边窗口所找到的器件 ,并在在窗口中，直接拖放器件OP215A到页面中心(窗口显示如下) 

 
5.4 放置竖着的电阻器 RES-SMD1206-100K: 

a. 同第三步， 选择Library = “resistor” ; Field = “DEVICE ” 

c. 设置 “Operator to” “=” “like”. 

d. Value 输入 “RES*” ; 选择”+”来过滤电阻器件 

f. 从列表中选择 RES-SMD1206-100K 电阻器. 

g. 在“part preview”面板中, 从下拉列表中选择 res:res.2  

h. 选择并拖放电阻器到OPAMP的左下角. 

i. 继续从下拉列表中选择res:res.1 ,改回到水平位的电阻器. 

j. 选中器件并拖放到OPAMP 的左边(与2脚（负信号）对齐. 

k. 选择按钮 “-” 重新设置. 



DxDesigner for PADS2007 flow Demonstration 

Mentor Graphics Corporation     Xue Wang (Technical Marketing Engineer) 10

5.5 用类似的方法放置其它3个器件 

 数量 

(# ) 

Library Field Operator Value 

1 Resistor DEVICE = RES-SMD1206-3K 

2 Capacitor DEVICE = CAP-SMD0603-100P 

放置完后显示如下: 

这里要应用到几个常用的器件命令： 

 

可以通过选中器件右键RMB,选择命令，例如 

>>移动器件:选中器件RMB,选择’Move’ 
 

或者通过菜单快捷方式: 

 

 

>>旋转:Format > Rotate or Toolbar:  

>>翻转:Format > Flip or Toolbar: Flip.  
 

 

5.6 空白处左键LMB取消所有的选择 

5.7 关闭 DxDataBook. 

 

5.8 放置电源通过 Toolbar: Power > builtin:vdd.1. 

 

 放置电源信号时，软件会自动端接到当前网络末端。右图所 示的

多个 

电源类型的选择，是通过 setup>setting中的 project>special component栏设置的 

5.9 放置 VDD symbol 在 OPAMP的第 8管脚  

5.10 右键 RMB取消选择模式 

 

5.11 同上步骤放置 Vee电源管脚 Toolbar: Power > builtin:vee.1 

 

5.12 查看器件属性:  Toolbar: Properties 打开 属

性窗口 

LMB选中器件，属性窗口中就会显示器件的属性 

 

也可 LMB选中器件 Op215A, RMB右键>properties 查看器件属性 

属性窗口中可以修改 RefDes（器件的位号） 

勾选表示在原理图中显示该属性 
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6.> 放置Nets及连接器件  

6.1 使用工具栏Toolbar: Net 进入 net 模式. 

 

6.2 按住左键 LMB 拖动鼠标完成网络 

6.3 选择 Toolbar: Select 来取消走线模式. 

完成走线后显示如右图: 

 

6.4 增加接地(Ground)连接  

6.4.1 选择100K电阻下面的连接 

6.4.2 选 择 Toolbar: Ground > 

builtin.gnd.1. 自动增加 GND到走线末端 

 

6.5 命名网络 :给两个网络命名为AMP_IN 和AMP_OUT 

 6.5.1 如果属性窗口没打开，选择 Toolbar: Properties 打开属性窗口 

 

 6.5.2 选中左边 100k的水平电阻,在属性窗口的”Name”内输入“AMP_IN” 

 同时，在Navigator窗口中自动更新网络名 

   
6.5.3 重复上面操作增加 “AMP_OUT” 网络到OPAMP器件的pin 1 

 

6.6 增加 Ports (页面端口) 

 6.6.1 选 择 AMP_OUT 网 络 , 然 后 选 择 Toolbar: Port > OUT > 

builtin:out_port.1 

  端口自动连接到该网络上 

6.6.2 移动网络名到 Por上方 ，更容易阅读 

 
6.6.3 同上，先选择AMP_IN 网络，然后选择  

Toolbar: Port > IN > builtin:in_port.1  

添加端口到网络上 
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7.> 原理图的编辑/修改  

7.1电路的拷贝 

 电路的拷贝有多种方法,如果是同一项目可以用类似于 windows操作系统，用 ctrl+c 拷贝，ctrl+v粘贴来复

制相同的电路图。 如果是外部电路，可以通过如下方法拷贝: 

 7.1.1 选择 Menu: File > Open >Block… 打开外部电路 

 

 

 

 

 

 

选择 Browse… 

打开 MGTraining\Demo_ECL_template 

 

选中 ECL.1，这时你打开的电路图是只读属性(在原理图窗口上方显示 “Schematic is in readnoly mode”)。 

 

 7.1.2 Menu: File > New > Schematic. 创建一新的原理图 

在浏览器(Navigator)的 Block项中会增加一新的原理图，选中原理图并右键 RMB>Rename修改名字为 “ ECL ” 
 

7.1.3 Menu:Windows选中 ECL ECL.1切换到外部 block视图进行拷贝 

框选中所有的器件，再点击 Menu: Edit>Copy命令拷贝(或者 Ctrl + C) 

注：1、确定选择过滤器中所有属性都被勾选   

 2、Setup>Settings>Advanced 栏中的 Unique names on copy不要勾选。 

 

 7.1.4 再切换回 ECL页面：直接点击 Navigator中的 ECL 原理图 

 运行 Menu: Edit>Paste (或者 Ctrl + V)粘贴到原理图中。示图如下: 

  

7.1.5 用同样的方法拷贝 ECL.2电路图。 
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7.2 放置 BUS总线 

在这个练习中,我们将在上一节拷贝的 ECL电路中创建两组总线 DA[0:7]和 HS[0:7]。并且我们会了解到如何画

总线，如何创建总线分支。 

 7.2.1 打开 sheet1,进入放置总线模式 Toolbar: Bus  

 在 74asl240器件的左上方画上一段短的总线（水平放置）。 

7.2.2 选中总线，打开属性窗口: Toolbar: Propertie  

命名总线为 DA[0:7]： 

按 ESC 取消走线模式，并切换到选择模式，选中总线名并调整到 

适当位置增强原理图易读性 

 7.2.3 从总线 DA端增加垂直总线，再把分支线连接到总线端，系统自动增加总线分支 rip及自动命名分支。 

 

 7.2.4 用同样的方法增加总线 HS[0:7] ,如下图 

 
 7.2.5 连接 pin到总线。 

 方法 1：直接用 Net命令从 pin到 bus连线，系统自动分配网络名到 nets上（网络标号从小到大自动分配）。 
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  在最上方的 74als240上分别完成  

Hs0 – Hs3 的连接 

 

 

 

文法 2: 使用 Rip nets命令 

 选中总线右键 RMB,选择 Rip nets命令,跳出 rip nets对话框, 选择网络 HS4 - HS7, 

点击 OK. 

4根网络分支附在光标上，拖动网络与左边的 74als240的四个 pin相连 

 

 7.2.6 使用相同的方法增加总线分支线连接（从 con电阻器 pin到 bus） 

 使用 Rip Nets 增加分支，然后应用 Toolbar: Resize Box  

来控制间距完成与 pin的连接 

 

 
 

完成总线后，原理图显示如下: 

 

(注：rip nets对话框可以选择排序的方式来控制网络分支排列方式) 

 7.2.7 修剪总线 , Toolbar: Cut Nets  
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7.3 添加端口:Ports 和 On/Off Sheet Symbols 

  在CLOCK网络上添加Onsheet Connector “builtin:onsheet.1”  

  在总线DA[0:7]（水平段）上添加Port Connector “builtin:in_port.1”  

  在~DS网络上添加“builtin:in_port.1”  

 

7.4 增加器件到网络上（自动割开网络 Splitting Nets） 

打开 ECL.2页面（sheet2），在 VCC和 74als04输入管脚 1脚之间放置一 3K的串联电阻。从 DxDatabook中找到

电阻 RES-SMD1206-3K ,拖放到 vcc网络上,如下: 

 

 
 

 选择 OK,电阻自动分开网络，一端网络名为 VCC,另一端自动 

分配一默认的网络名。 

 

7.5 查找/替换 Text 

 我们希望把项目中网络 Clock改成 HS_CLK网络名。 

7.5.1 打开 Menu: Edit > Find/Replace. 选择Replace栏。 

7.5.2 选择 MORE >>. (确定参数选择如下图) ;选择Replace All替换所有的clock网络成HS_CLK 

 
 
7.5 短接网络(Net Short) 

 连接网络 AUX_clock到 HS_CLK上，系统跳出对话框要求分配网络名。选择 HS_CLK网络,点击 OK。 
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7.6替换特殊器件(Replacing Special symbols) 

显示 amp原理图,选中 VDD symbol, RMB: Change > builtin:vcc.1 

 
 

7.7 替换 Symbols/Parts 

 打开 ECL的第 2页(ECL.2), 选中器件(Symbol), RMB: Replace Symbol 打开替换器件对话框。选择 Browse 

 

7.8 打断与器件的连线(Disconnect)  

 

有时在修改原理图时，需要换成另一类型的器件但保留大部分的网络连线，那应该先打断这些连线，再来删

除器件。MENU: EDIT >Disconnect 或者 Toorbar:  
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8.> 层次化设计  

 在原理图设计中经常会看到两种类型的设计，一种是平行设计：一个原理图 schematic下有许多 Sheet,

这种设计简单，但可读性较差。另一种就是层次化设计：把原理图分成许多模块，每个模块定义成一个 Block,

这样方便浏览检查…… 

 8.1创建模块器件(Bottom-Up Design) 

 模块化设计有两种方式，一种是通过已存在的原理图生成 symbol，这种叫由底层往顶层设计,另一种则

是由顶层往底层设计，先定义好 Composite symbol器件，再打开往里添加原理图信息。 

 

 8.1.1首先打开 ECL页面 1，选择 Menu: Tools > Generate Symbol 打开“生成 symbol”对话框 

 

 

 

 

 

 

 

 

 

 

>>选择 Advanced 

  

 在左边对话框中定义: 

 A、在 symbol Properties栏中删除 REF Designator=U? 

 B、修改 Pin Length = 0.200 

 C、在 pin sides中修改 IN =Right,Out=Left 

 >> 选择 OK 

 

8.1.2 修改/编辑 Composite Symbol  

 修改~DS管脚： 

 A、修改 Length=0.2 

 B、勾选 Out属性使其在 symbol中显示出来 

 

 修改 DA[0:7]管脚： 

 A、修改 Length=0.2 

 B、勾选 In属性使其在 symbol中显示出来 

调整 In,OUT文本信息到适当的位置。 

 

 增加新的属性：block 名 

 A、取消所有选择 

 B、在<new property>栏中，选择“Level” 

 C、输入值为 “ECL_BLOCK” 
 

 编辑完的 composite symbol显示如下: 

 

>> 保存退出 symbol 编辑器 
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8.1.3调用模块(利用刚刚生成的 local symbol)  

 运行(Menu: File > New > Sheet 创建 sheet2 

 进入到 sheet2原理图编辑窗中，打开 symbol放置模式:Toolbar: Symbols 

 

 

 从[local symbols]分区中选择 ECL.1 Symbol 增加到原理图的左下区域。在 Properties的 name中输入

ECL。 

此时也可选中 symbol右键 RMB: Push Schematic 来查看修改 Block的内容及进行修改。 

 

8.2 创建 Top-Down 设计 

  我们将通过创建一”Memory”模块来了解如何进行顶层往底层的设计模式 

8.2.1 创建 Memory Block  

 在原理图左上方，点击 Toolbar: Block   

在原理图左上方画出一方框,跳出对话框 

  输入 Block Name = Memory 

8.2.2 从 ECL_block 的 “~DS” pin 上拉出网络连接到 Memory 

block上，自动会在 block连线处增加 pin, 点击 Menu: View > Properties ,命名网络为 “~DS” 

  

8.2.3 用走 Toolbar: Net 的方法分别完成~RAMRD; MEM_BUS ; D[0:15]; A[0:7]; DA[0:7] 。如下图: 
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 8.2.4 选中 block, RMB：PUSH schematic,打开 Block编辑窗口 

 

 

 

 

 Menu: File > Open >Block… 打开“Demo_Memory_template”项目， 

copy原理图所有内容到 Memory模块中 

 

 

 

 8.2.5 用同样的方法创建 Block “DtoA” ,如下图。（分别连接网络 MEM_BUS, ~RAMRD, DA[0:7]） 

 
打开 DtoA模块（RMB: Push Schematic），拷贝 “ Demo_DtoA_template” 原理图所有内容到 DtoA模块中 
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9.> 设计的检查及校验  

 9.1 通过 DXDataBook检查单页原理图的器件信息完整性。 

   打开项目文件 c:\MGTraing\Demo_design 

 9.1.1 打开 DxDataBook Menu: View > Other Windows > DxDataBook 

 并打开原理图 ECL.2 

 9.1.2 点击DxDataBook窗口左边的 New Live Verification Window  ,显示类拟如下的窗口: 

 

 注： 

 黄色标志：表示该器件在器件列表 

  中不是唯一的 

 红色标志: 表示该器件在器件列表 

 中没找到。 

 

 

 

 

9.1.3 双击红色标志的器件 caps:cap.1 ,在右边窗口显示没有找到value=5pf的器件（显示为红色），找到

CAP-SMD0603-100P的器件，运行Annotate Component with All Properties  替换选中器件。 

 

 此时左边的caps电容标志颜色变成绿色。用同样的方法更新caps:cap.2电容。 

 

 9.2 通过 DXDataBook检查层次化原理图的器件信息完整性。 

 9.2.1 点击DxDataBook窗口左边的 New Hierarchical Verification Window  ,指定design为检查对象 

 9.2.2 运行Verify All Components in the Current Design  显示类拟如下的窗口: 
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 9.2.3 双击黄色标志的器件 als_74:74als30.1 ,在右边窗口显示多个匹配，选中PartNumber= *_SOP 

 9.2.4 选择 Add Part to the Pending List  

 

所有74ALS04器件被替换，黄色图标变成绿色,状态也显示为OK 

 

 9.2.5 选择 Update Design 更新设计 

9.2.5 关闭DxDataBook 

 

 

 9.3 电路 DRC检查 

 9.3.1 Menu:Tools > Verify… 打开检查对话框 

 

选择Default设置参数 

 

9.3.2 切换到Rules设定栏 

里面有4组参数分别为: 

>> Migration 

>> HDL Checks 

>> Voltage 

>> Others 

勾选其中希望检查的选项，分析结果分

别以: 

Errors – 红色字体显示. 

Warnings – 蓝色字体显示 

Notes –黑色字体显示 
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9.3.3 选中others选项，并勾选drc-11: Missing bloxk pin property。 得到如下结果: 

 

 这里我们并不需要去增加相应的属性到这些symbol上，因为这些是block symbols。 

 9.3.4 清除Output窗口信息 RMB: Clear  

  

 9.4 原理图诊断 Menu:Tools > DxDesigner Diagnostics 。 
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10.> 规则定义 (Constraint Editor) 

 10.1 物理规则定义--间宽/线间距定义 

10.1.1 打开项目文件 c:\MGTraing\Demo_design  

 10.1.2 打开 Menu: View > Other Windows > Constraints, 

选择网络 D0 

 

 

 切换到 Clearance栏 

 Object 选择为 Nets 

 

 最小线宽=5   ;单位默认为 mil 

 推荐线宽(默认)=6 

 最大线宽=8 

 

 

10.2 创建 Netclass 

10.2.1 指定网络到 default组 

选择对话框下面的  

Toolbar: Create New Class from Settings  

 设定为默认的 netclass (default) 

 

 勾选”save settings as the default class” 
 点击 OK退出 

 
 

10.2.2 创建新的组 Mem_Address 

 选中网络 A0,点击  打开组定义 

 输入组名:Mem_Address 

 再选择”OK” 
 

 

 

 

 

 

 10.2.3 赋 A[0：7]到 Mem_Address组中 

 在左边的 Navigator,找到网络 A[0:7],先选中 A0,再按住 

Shift+LMB选中 A7,选中 A0~A7共 8根线 

 

在 constraint窗口中，会显示所有网络的定义 

 

继续按住 Shift+最末尾的网络（class）框，显示如下图: 

选择组名为 MEM_ADDRESS 

或者 点击 PCBCLASS栏，选中所有列， 

在下拉单中选择 Mem_address 
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 10.3 高速规则定义—延时定义 

10.3.1 选择网络 HS_CLK ,在 constraint窗口中切换到 High Speed栏  

 

  最小延时=0.2 

  最大延时=0.35 

 

 10.4 高速规则定义—走线长度定义 

 10.4.1显示 ECL.1 原理图，选择 HS0 
  (使用 Navigator快速选择) 

 10.4.2 选择 High Speed栏 

 10.4.3 最小长度=2500 

   Match Lengths=True 

   Matched Length Tolerance=10 

 

 

使用相同的办法完成 Hs[0:7]的规则定义 
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 10.5 高速规则定义—差分对定义 

 10.5.1显示 DtoA模块，选中网络 DP1-POS 

 10.5.2在属性对话框中，选择 Diff Pair栏 

 10.5.3在下拉单中，选择 DP1-Neg网络 

 10.5.4 使用 Navigator同时选中 DP1-POS, DP1-Neg网络 

 10.5.5 在 constraint窗口中，显示如下: 

 

 输入 Length Max,Trace width,Gap来定义差分对走线参数 

 

 



DxDesigner for PADS2007 flow Demonstration 

Mentor Graphics Corporation     Xue Wang (Technical Marketing Engineer) 26

11.> 原理图数据到PCB数据(DxDesigner to Pads Forward Annotation) 

11.1 运行 Menu: Tools > PCB Interface ,选择”STD” 

 

运行 OK,得到如下错误信息: 

 
11.2 打开 DtoA原理图，选中器件（或者直接在 log窗口中双击”Error6035”,将交互指向到错误发生处 

 

输入 value值为 100 
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 11.3 重复 forward 操作，直到没有任何错误显示: 

 
 

 11.4 调入 PCB模板数据 

  在 DxDesigner to pads layout对话框中选择模板文件为 C:\MGTraining\common\config\PADS\default.pcb 

 

 选择 Next> ,选择库的导入 

 

选择 Finish, 完成前标工作。并且会自动进入到 pads layout窗口中。 
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在 Layout 窗口中，运行 Menu: Tools > Disperse Components 打散开器件进行布局 
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Appendix 1---- Interconnect Edit (ICE)介绍 

 

 

Appendix 2---- 原理图文档处理 

 A2.1 产生Parts List (Menu: Tools>PartLister) 

 

 A2.2 原理图标注Cross Reference (Menu: Tools>Cross Reference) 

 

 A2.3 PDF文档输出DxPDF (Menu: File>Export>PDF) 

 

 A2.4 设计存档Archiving (Menu: Tools>Archiver) 
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Appendix 3---- Software and Application configuration 
1.) 课程:  DxDesigner for the PADS Flow 

2.) 平台: 

• METNRO软件要求系统为 Windows XP Service Pack 2(及以后的版本) 

• 对于所有的平台信息请查看 http://supportnet.mentor.com/systemreqs (选择 PADS2007.4版本) 

3.) 软件要求: 

• PADS Flow 2007.4 10/9/08 (for Windows)  
o  PADS Logic  

o PADS Layout  

o PADS Router  

o DxDesigner  

o DxDatabook  

o Variant Manager  

o PADS Libraries 

• PADS Flow 2007.4 Update 1 (11/04/08) (patch)  

4.) 培训数据: 

§ MGTaining.zip 

5.) LICENSING要求: 

• 所有软件都可运行在 feature : “mgc_s” . 关于其它 license的要求,详细信息参考 SupportNet 

6.) 数据准备和软件安装 

1. 安装MGC license 文件. 

2. 安装 PADS Software. 

3. 拷贝 TRAINING DATA, placing the data in C:\. 

7.) 系统变量要求:  

• MGC_HOME  =  path to MGC software tree 

• MGLS_LICENSE_FILE  = path to MGC license file  (c:\license.dat should be the default) 

• DASH_SHELL_NOTIFY= FALSE 

• DESIGNER_NOPRIMARYALIAS  = 1 

• WDIR =C:\MGTraining\projects\local_config; C:\MGTraining\common\config;   
 C:\<install_dir>\2007.4PADS\SDD_HOME\standard 

Notes: <install_dir> 默认是 MentorGraphics, 但每个安装或许不同.路径分号隔开 

• PATH默认是MGC_HOME/bin. 

8.) 安装完成测试 

为了验证是否已安装正确,通过下面步骤检查: 

1. 检查是否 C:\MGTraining目录下已存在’common’ 和’projects’ 子目录. 

2. 检查注册系统是否已正确更新. 

a. 在windows中选择打开: Start > Control Panel > Administrative Tools > Data Sources (ODBC).  这将打开ODBC数

据管理对话框. 

b. 选择 User DSN 栏, Highlight the DxDClass. 

c. 选择 Configure, 确认 DxDClass 是否指向 C:\MGTraining\common\libraries\dxdatabook\DxDClass.mdb. 

3. 检查软件是否否已正常安装 

a. Start > Program > Mentor Graphics SDD > Design Entry > DxDesigner.调用 Dxdesigner是否正常 

 
 

http://supportnet.mentor.com/systemreqs

